Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Debian gnome desktop environment in a Virtual Box instance on my laptop. The default resolution of the Debian desktop extends outside of the Virtual Box window.

I went to System > Preferences > Screen Resolution to change it, but it was greyed out. The dropdowns "Screen Resolution", "Refresh Rate", etc were empty, and when you click on the thing to drop down the menu, the boxes grey out. Why is it blank/grey, and how can I change the screen resolution?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

If you haven't already, the first thing to do id install the VBox Guest Additions, doing so will give you a few more options for controlling the screen size from the VirtualBox machine menu.

It's likely that your installation will not be configured for compiling kernel modules, so trying to install the Guest additions may fail without some initial preparation. Before doing that, try installing the Guest additions:

  1. Select 'Install Guest Additions… from the Devices menu
  2. If the CD is not mounted automatically, run mount /media/cdrom
  3. Run sh /media/cdrom/VBoxLinuxAdditions-x86.run (replace -x86 with -amd64 if 64 bit)

If you receive an error message related to kernel headers you will need to carry out some additional steps:

  1. Open a root console
  2. Update your APT database with apt-get update
  3. Install the latest security updates with apt-get upgrade
  4. Install required packages with apt-get install build-essential module-assistant
  5. Configure your system for building kernel modules by running m-a prepare

This may take a while depending on the speed of your Internet connection. Once the above has completed, try running through 1 to 3 again.

If, once you have completed the above you find you still cannot resize the VBox window correctly, you may have to edit /etc/X11/xorg.conf

share|improve this answer
    
I have only the first install cd of debian 5.0.2. Couldn't find VBoxLinuxAdditions-x86.run anywhere on it. Where is the "Devices" menu? –  user13743 Jun 20 '10 at 18:13
    
The guest additions are part of VirtualBox. When you start your virtual machine there is a menu at the top, select 'Devices' then select 'Install Guest Additions' –  Pulse Jun 21 '10 at 6:47
    
That did it! ...but the max resolution available is 800x600. Is it time to edit xorg? –  user13743 Jun 21 '10 at 14:02
    
If you've got the guest additions installed, you should now have some additional options on the VM 'Machine' menu and you should be able to resize the VM manually. –  Pulse Jun 22 '10 at 2:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.