Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using vmplayer 3.0.0 build-197124 on Windows 7 Pro as host and installed Ubuntu 10.04 as guest OS. On booting into Ubuntu , it cannot detect the keyboard. How do I fix this. I also installed a Opensue 11.1 VM and the keybaord worked fine.

share|improve this question
up vote 0 down vote accepted

One work-around is to enable the virtual keyboard (through the accessibility options at the login page). Login and then make a quick change to /etc/default/console-setup. Find XBVARIANT and remove the value for it, leaving you with
XKBVARIANT=""

Some other options are mentioned in the comments of this blog post: http://www.solo-technology.com/blog/2010/05/01/ubuntu-10-0-4-vmware-and-no-keyboard

share|improve this answer
    
just to add that after selecting the Universal access and OSK, you need to reboot the OS once to get the OSK... – iceman Jun 23 '10 at 10:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .