Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 computer won't connect to the Internet using WiFi. When I open Internet Explorer it can't find any pages - if I try to use the guide to solve the problem it says that the DNS server isn't responding. I have tried the following without any luck:

NETSH INT IP RESET
NETSH WINSOCK RESET

My Windows Vista computer connects to the Internet via WiFi without any issues. The only difference I can see is that when I run ipconfig, the Vista machine has a "Link-local IPv6 Address" but the Windows 7 machine doesn't.

Does anyone have any ideas how to fix this?

UPDATE: I believe this may be connected to DNS, because I can access Google via its IP: http://209.85.229.10

share|improve this question
    
You could always try using the opendns name servers en.wikipedia.org/wiki/OpenDNS You might also consider turning off DNS relay if your router/WAP is using it. Though for the later you might need to reboot the router and then renew your DHCP lease (ipconfig /release followed by ipconfig /renew) to make sure the DNS server IPs get pushed down to the client you are working on. You can use ipconfig /all to check which DNS servers you are using. –  irrational John Jun 21 '10 at 15:34
add comment

4 Answers

You might try to disable IPv6. This is explained in detail in this article:

How To Disable IPv6 In Windows 7

share|improve this answer
add comment

You probably already did that, but try to update wifi drivers for you Win7 machine. It suddenly helped me month ago.

share|improve this answer
add comment

It is hard to provide suggestions when you do not provide info about what sort of network your Win 7 computer is attempting to operate in.

Some questions off the top of my head ...

  1. How are your systems connected to the Internet? I am assuming you have a router/WAP and either a DSL or cable modem. But it would help to know for sure and to know which make/model of router/WAP you are using.
  2. How complicated is your LAN? How many systems and/or devices are connected to it?
  3. Can you connect to your LAN router from the Win 7 computer using a wired ethernet connection?
  4. Can you connect to your router from the Win 7 computer using wireless?
  5. Is your router using any sort of local access filtering? For example, is it restricted to only allowing specific MAC addresses?
  6. Is this possibly a DHCP problem? Perhaps the maximum number of allowed IP addresses already been assigned by the routers DHCP?

Could you post the info returned by running ipconfig with no other parameters on this Win 7 system?


I belive its something to do with the dns since i can visit google by typing in the ip in the browser

So what is different between the DNS settings for the Vista laptop and the Win 7 laptop?

Does ipconfig /all show that both laptops are using the same DNS server IP addresses when connected via Wi-Fi? (I would also check what you get when you use wired ethernet to connect).

You could also try using nslookup in a command prompt on both to see what happens when you attempt to resolve www.google.com.

FWIW, here's a link to a MS Knowledge Base article: Using NSlookup.exe

Keep in mind that if it is a DNS problem one would expect it to show up on all the computers using the router since they all should be using the same DNS servers. This doesn't appear to be the case so something must be different.

My first guess is that something is wrong with the DNS servers assigned to the Win 7 laptop.

Unfortunately, I do not have a second guess at the moment.

share|improve this answer
    
1) yes im using a router, and i belive that the router works fine since my vista machine connects both to the nerwork printer and the internet with no problem. My Win7 machine can only communcate with the networkprinter, not the internet. 2) Its pretty simple one router with build in wifi. 1 pc connected by cable(win xp) 1 laptop(vista) 1 laptop (win7) 3) Yes wired connection works fine, i can even connect to the internet using wired connection 4) Yes it connect to the router and i can use the network printer 5) No, and everything worked prefectly until yesterday 6) Dont think so –  Cruelio Jun 21 '10 at 14:16
    
I belive its something with the dns to do, since i can visit google by typing in the ip in the browser –  Cruelio Jun 21 '10 at 14:26
add comment
up vote 0 down vote accepted

I ended up reinstalling the OS

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.