Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The command Select Word in TextMate considers certain characters to be word boundaries. The most frustrating is - [hyphen] which makes variables that contain a hyphen to be unselectable. Less egregious is $ making selecting the full variable in PHP somewhat annoying.

Has anyone come across a solution for this, like maybe a bundle that implements their own version of word selection?

share|improve this question
up vote 4 down vote accepted

Go to Preferences > Text Editing and change the options under "Word Characters".

share|improve this answer
    
wow right in front of me. thanks! – AK. Jun 20 '10 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .