Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I enable Compiz (System > Preferences > Appearance > Visual Effects), all the windows start to act funny with the mouse.

Wherever I click on any window with the mouse, it acts as though I was clicking on a titlebar. I can grab and move the window when I left-click it and when I right-click, the titlebar menu appears. All this prevents me from touching any object of the window I'm working on.

This happens with minimal, normal or any configuration, and prevents me from using Compiz at all.

BTW, this it a fresh install of 10.04 not an upgrade. I am re-installing all compiz packages to see if it gets fixed.

I just noticed that the mouses works ok while I hold down the CTRL button.

share|improve this question
2  
i'm not sure what effect you're running into, but you might want to install the compizconfig-settings-manager package -- CCSM is much more comprehensive than the Appearance > Visual Effects tab. –  quack quixote Jun 21 '10 at 3:05
1  
It sounds like a setting got inverted (the ctrl modifier part, for example). For example, holding super/winkey and left clicking anywhere in a window allows me to move that window (very useful), but I forget what the default key is for this setting. –  Roger Pate Jun 21 '10 at 4:32
add comment

2 Answers

run ccsm go to window management -> move window and change "initiate window move" setting to " control button1 "

share|improve this answer
add comment
up vote 0 down vote accepted

Well, I never found the root cause, so I ended resetting the whole gnome configuration:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

This wipes the whole desktop configuration.

It's like using a sledgehammer for a small nail, but it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.