Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Spotify on Linux using Wine.

Sound worked great (even though the sound test in winecfg failed!), until I installed alsa-oss package yesterday to get Flash sound working in Firefox.

Now Spotify says: "There is a problem with your sound card. Spotify can't play music."

So the question is, how to get the sound in Spotify working again, so that it also keeps working in Flash & Firefox? Tweak some ALSA settings? Spotify settings? Add/remove some packages?

By the way, curiously, now that sound doesn't work in Spotify, winecfg's "Test Sound" does work!

This is Ubuntu 8.04 (Hardy). Sound card / driver is probably an integrated AC'97. Please mention if any additional information about the system is needed!


Update: I have Flash 10 installed (outside the packaging system, using $MOZ_PLUGIN_PATH env variable), but also had Flash 9 from flashplugin-nonfree package - and the earlier version was being used by Firefox! Based on what Mike Arthur said about Flash and alsa-oss, I removed the older Flash (flashplugin-nonfree package) and alsa-oss - and Flash sound still works, which is nice. But for some reason Spotify still doesn't play sound, even though things should now be like they were originally...

Update 2: Got it working, all smoothly, finally.

share|improve this question
add comment

5 Answers

up vote 6 down vote accepted

Update (2012)

For a couple of years now there's been a native Linux version of Spotify, which, albeit labeled as "preview", is fully functional in my experience and should be your primary option. Use that, and at least you'll bypass any Wine-related audio problems.

Leaving my original answer below, just in case it might be helpful for someone:


Original answer (2009)

Ok, got it working by both removing alsa-oss and tweaking audio settings from winecfg. I changed from ALSA Driver to OSS Driver; see screenshot below.

The problem with OSS driver seems to be that any one application blocks all others from playing sound; for example, if Spotify is open (but not even playing music) - I can't get any sound from Audacious. Actually this sucks pretty much - sometimes when I open Spotify it won't play sound, and I have to track down which process is blocking the sound device - even when no audio is playing.

So I'm definitely still open to better solutions -- perhaps with ALSA, but so that Wine/Spotify would play nice with it too?


Update: Ok, got Spotify to work with ALSA (again?). I'm not exactly sure where the problem was; what I did was go to ~/.wine/drive_c/windows/profiles/[username]/Application Data/Spotify, deleted everything, and launched wine spotify.exe again. Apparently there were some incorrect settings remaining, and re-launching Spotify afresh fixed the situation.

Anyway, now Spotify, Flash in Firefox, and other apps can all play sounds smoothly, without blocking each other.

To summarise, this is what worked for me:

  • Use Flash 10; make sure Firefox's about:plugins contains only "Shockwave Flash 10.0".
  • Use ALSA everywhere1. As Mike Arthur commented, forget about OSS (and alsa-oss).
  • (Try clearing Spotify's application data.)

1 Wine's audio configuration (winecfg) should look something this:

alt text

share|improve this answer
    
You shouldn't be using OSS full-stop. Look at enabling DMIX for ALSA (if it isn't already enabled). –  Mike McQuaid Jul 30 '09 at 12:29
    
Thanks. Got it working with ALSA now; see the updated post. (I don't know where to configure DMIX for ALSA stuff - either that isn't needed, or it was enabled already.) –  Jonik Jul 30 '09 at 14:13
add comment

That's a really old link, you shouldn't need alsa-oss for sound in Flash if you are using a recent Flash plugin.

Either consider upgrading Hardy to a newer Ubuntu, upgrading the Flash package to one from backports or roll your own Flash package based on the latest version.

share|improve this answer
    
Thanks for "you shouldn't need alsa-oss for sound in Flash if you are using a recent Flash plugin" - that seems to be correct! Still no sound in Spotify, for some reason - see updated question. (For the record, I do not want to upgrade the whole system, right now, just because of this - and I shouldn't have to, as I now have the latest LTS version.) –  Jonik Jul 30 '09 at 10:26
add comment

Spotify now has a real linux client (beta) that works very nicely for me!

share|improve this answer
1  
Ah, thanks! I'll check it out when setting up my next Linux workstation soon. (Can you add a link or something to the answer?) –  Jonik Sep 15 '10 at 20:41
    
The beta is here: spotify.com/se/download/previews –  sandos Sep 29 '10 at 12:05
add comment

I went into Wine's configuration, to the Audio tab and set DirectSound hardware acceleration to "emulation". With ALSA, it fixed the problem in my case (same setup and error as poster).

share|improve this answer
add comment

This PPA source has a wine package with pulseaudio support

https://launchpad.net/~neil-aldur/+archive/ppa

I use it with Spotify and it works ok.

share|improve this answer
add comment

protected by nhinkle Apr 26 '11 at 23:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.