Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the configuration it is still set to remember my history. When i type in autocomplete it remembers the sites i visit yesterday. However everything iam doing right now isnt showing up in autocomplete and when i search my history it isnt there either. I tested by pasting a url to a valid page. Browse to another, closed Firefox, typed the domain, pasted the domain and still no history or autocomplete.

share|improve this question
    
Do you use something like CCleaner? –  Ivo Flipse Jun 21 '10 at 8:00
    
Nope. My hardisks space did drop and i did install CrystalDiskInfo in the past 2 days. –  acidzombie24 Jun 21 '10 at 8:20

4 Answers 4

Make sure you're not running the browser in private browsing mode, and make sure that you don't have any cleanup utilities that wipe the history/cache of your browsers. If neither of those are the culprit, I suppose there's a possibility that the browser can't write to the files.

share|improve this answer
    
Thats how this problem started. No disk space. I have 4gb+ and restarted my PC. Firefox still doesnt remember. –  acidzombie24 Jun 21 '10 at 8:31

Quick solution without backup. Delete places.sqlite in your profile

Longer Solution: copy a firefox shortcut and add -P old -no-remote to the end (mine is "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -P old -no-remote). Click create profile, create one called old. Double click default (so it remains default and should now launch it). Double click the shortcut and it should launch a fresh firefox profile. Close them both.

Copy everything from default folder to the old folder (location here). Launch the old shortcut and it should be the copy of your current broken profile. Go to default and delete places.sqlite. Your history along with the problem should be gone with everything else intact. You can access the history via old.

related links

https://support.mozilla.com/en-US/kb/Managing+profiles https://support.mozilla.com/en-US/kb/profiles https://support.mozilla.com/en-US/kb/Recovering+important+data+from+an+old+profile

share|improve this answer

You just go into options, privacy and if it has all these settings under privacy you just unclick "clear history when Firefox closes"

otherwise just change it to "Firefox will: remember history" from the drop bar in that same privacy option

share|improve this answer

I do not know if you look the options so I am writing ... tools - options - privacy - remember history ? ( also at the bottom there is an option to show suggestions for location bar - I think it should be selected as history and bookmarks)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.