Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on Ubuntu 10.04 with GNOME 2.30.

Once every couple of days, I might be pressing something or doing something – I haven't found out what it is, though last time I was pressing the "mouse lock" button on my on-board mouse on my laptop – my keyboard simply locks down.

Some keys work, like ALT+CTRL+F1-6 and also ALT+SHIFT still changes the keyboard layout, but everything else doesn't work, no letters, no other shortcuts.

To fix it, I go to ALT+CTRL+F1 (Terminal) and run

sudo /etc/init.d/gdm restart

But I'm getting kinda tired of doing that every now and then. Any ideas if in Gnome there's a shortcut for "Kill my Keyboard" or something?

share|improve this question
Do you use USB keyboard? I have similar problem, getting 'Unable to enumerate USB device…' – takeshin Jun 22 '10 at 16:46
Please don't use <br>s to break lines. They're automatically wrapped. – slhck Feb 8 '12 at 11:24
I don't see that anybody has addressed the cause of the problem. – carbontax Mar 29 '13 at 13:57
up vote 2 down vote accepted

I'm guessing that your X server is getting confused, based on the facts that a) your keyboard gets you to a working console and b) killing X (via gdm) clears the trouble.

Unfortunately, stock Lucid disables the "Kill X Server" Ctrl-Alt-Backspace sequence. Fortunately enabling it is easy System > Preferences > Keyboard > Options... > Key Squence to kill the X server.

Yes, you'll still be killing X, but it will be faster. /var/log/Xorg.log.0 may give you some hints as to the failure, or perhaps syslog or dmesg or kern.log. Happy hunting.

share|improve this answer
Good stuff, msw. – mcandre Jun 21 '10 at 17:59
Ctrl+Alt+Backspace is deprecated...use the Magic SysRQ Key instead: Alt+Print+K. – Bobby Aug 30 '10 at 9:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.