Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to leave my UAC settings unchanged but every time Notepad++ starts, I get a UAC prompt. Is there a way to set exceptions for known programs?

alt text

share|improve this question
    
OH MY GOD! What a horrible theme you have... –  Ivo Flipse Jun 21 '10 at 20:26
2  
OMG! Windows 7 with Windows Classic theme. Fail. –  Hello71 Jun 21 '10 at 22:11

3 Answers 3

up vote 3 down vote accepted

Not an answer to your broader question, but np++ should only be prompting you if you try to start it as an administrator. If you're not doing that yourself, double check that the compatibility settings don't say "Run this program as an adminstrator" (Right click on notepad++.exe -> properties -> compatibility).

share|improve this answer
    
Ahh, I have to run it as an administrator because of some of the files I use it to edit.... –  Matt Jun 21 '10 at 18:55
2  
@Matt: Then change ACLs on those files. –  grawity Jun 21 '10 at 19:13

No, I really don't think there is.

I have to run Visual Studio 2008 as Administrator, and I've never been able to figure out a way to suppress the dialog just for VS2008.

share|improve this answer
    
This seems like a poor oversight on MS' part –  Matt Jun 21 '10 at 18:56
    
Aye, Matt. Aye. –  mcandre Jun 21 '10 at 19:03

There is a work-around that utilizes the task scheduler, see this page. This is supposed to work for both Vista and 7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.