Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Redhat 5 Enterprise (Nautilus 2.16.2) with Gnome and am having trouble changing the default application for PDFs. No matter what I do, it seems to always come up as evince.

First I tried browsing to a PDF file using Nautilus, right clicking on a PDF file, selecting properties, open with, and then changing the radio button. However, the radio button is selecting "Document Viewer" and clicking on the other buttons doesn't do anything. The button is stuck on "Document Viewer" (I'd like to use Adobe Acrobat).

I thought I'd do it manually then. Running `gnomevfs-info file.pdf" shows:

Name              : file.pdf
MIME type         : application/pdf
Default app       : evince.desktop

xdg-mime query default application/pdf used to show the same result but after running xdg-mime default AdobeReader.desktop application/pdf it now shows this:


So now xdg-mime and gnomevfs-info are showing different default applications for this file type. I've tried updating the mime database using update-mime-database ~/.local/share/mime as well as updating my desktop database using update-desktop-database ~/.local/share but nothing seems to be working.

Changing a default application really shouldn't be this difficult. What should I try next to change my default application?

, however, shows something different

My .local/share/applications/defaults.list file, however, shows the following:

share|improve this question

You have to click on the actual radio button, not just the different entries in the listbox.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .