Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem with Hibernating my Windows 7 PC. When ever I try to hibernate, the screen goes blank for a while, there's disk activity and then I am presented with the Login Screen.

I've tried enabling/disabling hibernation, not helped. When I run shutdown /h I get a error: "The system cannot find the file specified.(2)"

I've checked and "hiberfil.sys" does exist.

How can I get hibernation working again?

EDIT: Just ran shutdown /h and monitored it with Process Monitor (something I should have done at the beginning) and the only file it cannot find is "C:\Windows\rescache\rc0008":

08:10:24.6198561 AM shutdown.exe    3684    CreateFile  C:\Windows\rescache\rc0008  NAME NOT FOUND  Desired Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a

I went to "C:\Windows\rescache" and saw:

rc0006 (Folder)

rc0007 (Folder)

ResCache.mni (File)

Now I tried just copying rc0007 and rename it to rc0008 but I get a access denied error (even when running as Administrator). Should I bother going into safe mode and copying and renaming rc0007 to rc0008. Will it help? Does this shed some light on the problem?

share|improve this question
    
Do you use original Windows 7? I mean.. loaders and mods can cause this. A lot of people were talking about such problems and finally I found out that their loader ruined it. (Just an idea, no offense.) –  Shiki Jun 22 '10 at 9:39
    
No, none that I know of. Is there a way to tell if there is one installed (I'm thinking a virus/another user...)? –  Kryten Jun 22 '10 at 10:03

4 Answers 4

Because your sistem partition is not active anymore

click start - right click "Computer" - click "Manage" - go to Storoge - Disk Management - Right Click Windows Partition And "Mark Partition As Active"

share|improve this answer
    
Worked for me -- thanks. –  mbq Mar 9 '12 at 23:50

Try recreating the hibernate file:

  1. Open cmd.exe in admin mode, by typing cmd in start menu and pressing Ctrl+Shift+Enter
  2. Type powercfg -h off
  3. Type powercfg -h on

Check if you can hibernate now.

share|improve this answer
    
No it still doesn't work. Tried running "shutdown /h" again and got "The system cannot find the file specified.(2)"... –  Kryten Jun 22 '10 at 10:15
    
Was there any error when you tried to turn -h off or -h on? –  KalEl Jun 22 '10 at 11:04
    
No, there were no errors (there was actually no output at all). I also ran "sfc /scannow", but still not working... –  Kryten Jun 22 '10 at 11:06
    
Have just done a System Restore: still nothing –  Kryten Jun 22 '10 at 11:59
    
Did this start happenning after you did something specific? –  KalEl Jun 22 '10 at 13:40
up vote 0 down vote accepted

Fixed the problem. On the "advice" from a friend, I set the active partition from the 100mb "System" to C:. Restarted, "Windows Boot Manager Failed to Load Windows". Inserted installation DVD and select "Repair your Computer". When it was searching OS's it came up and said I had a boot manager problem and do I want to repair it? I did and Windows loaded. I can now hibernate! I can also see Windows 7 listed in the “Start-up and Recovery” Options (see this question). Windows boots instantly and is actually a lot snappier! I have no idea how this could have helped, but it did. The only problem is that the Windows Boot Screen is the old "Vista" style (i.e. just a progress bar at the bottom), so anyone knows how to fix this, then please say.

share|improve this answer
1  
I don't understand you friend's advice to change the partition marked as "active" (bootable). This strikes me as a kludge to force "Repair your Computer". You should have been able to boot the Win 7 install DVD and "Repair your Computer" without mucking around with your partitions. Oh, well. –  irrational John Jun 23 '10 at 16:50

Got the same problem:

>shutdown /h
The system cannot find the file specified.(2)

My solution was enabling automount via diskpart.exe:

Microsoft DiskPart version 6.1.7601
Copyright (C) 1999-2008 Microsoft Corporation.
On computer: FELIX-T420SI

DISKPART> automount

Automatic mounting of new volumes disabled.

DISKPART> automount enable

Automatic mounting of new volumes enabled.

DISKPART>

Following a restart, hibernation now works.

share|improve this answer

protected by studiohack Apr 27 '11 at 21:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.