Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had flash problems for most of the time I had flash installed on my 64bit Ubuntu install. The flash elements on pages seem very buggy, clicking on things in the flash frame fails first, then eventually the flash video won't even play. The main problem however is my inability to click on controls in the flash area. Please help, this is killing my ability to watch video online from my home.

share|improve this question
    
First it loads up the nspluginwrapper. Then, it loads the 32bit crosslibs. Then, it loads the flash plugin. It may or may not work actually. (Okay there is a solution I guess, I just don't know and never seen a way.) Since Adobe dropped the 64bit release for the time being, you should stick to 32bit or change to a desktop operating system (no flame/offense, Xorg is not for desktop). (Maybe you can search up the old 64bit plugin, but expect crashes and slowness!) –  Shiki Jun 22 '10 at 17:41
    
"Xorg is not for desktop" <-- eh? what's it for then? toasters? –  ThatGraemeGuy Jun 22 '10 at 18:26
    
comment from AndrejaKo: Hey guys, same issue here. I tried the script and .deb, but it didn't solve the problems. Anything else that may help? –  quack quixote Jun 22 '10 at 19:25
    
this might be a duplicate of superuser.com/questions/153028/… ... –  quack quixote Jun 22 '10 at 19:26
add comment

3 Answers

If you haven't tried it already you can get the latest version of the Ubuntu Flash player from Adobe (in APT style). Just head over to this web page.

Also, here are some instructions about getting/updating Flash Player 64-bit, for Ubuntu 10.04 64-bit, from the repository.

HTH

share|improve this answer
    
First is somewhat OK but I don't know how it would play out with this crosslib, nspluginwrapper solution. | 2nd is outdate, Adobe killed its 64bit beta plugin with the security problem just before the 10.1 release (or they used it as a scapegoat). –  Shiki Jun 22 '10 at 18:08
add comment

Do you still have the issues if you disable visual effects under System > Preferences > Appearance > Visual Effects?

share|improve this answer
add comment

You need to set GDK_NATIVE_WINDOWS to 1 for your web browser. See https://bugs.edge.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407

If it is a mozilla-based browser, you can put the following in ~/.mozilla/firefox/rc

export GDK_NATIVE_WINDOWS=1

That's what works for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.