Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have linux mint 9 as guest os in virtual box. With windows 7 as host. Is it possible to enable the rich visual effects of linux mint 9 inside virtual box?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You'll probably have to install the VirtualBox Guest Additions

share|improve this answer
    
You might also need to allocate more video memory to the virtual PC, possibly turn on 3d and or 2d video acceleration? –  Richard Jun 23 '10 at 12:12
    
how do I do that? –  soul Jun 23 '10 at 12:14
    
no luck after installing guest additions, it still says that desktop effects could not be enabled –  soul Jun 23 '10 at 12:36
1  
Did you enable 3D acceleration? How much memory have you given to the Video memory of the Guest OS? Make sure you are using the latest drivers for your graphics card. Enabling 3D acceleration often crashed my Ubuntu guest OS until I updated the video drivers to the latest version. –  Om Nom Nom Jun 23 '10 at 13:33
1  
If you're after Windows Aero, you need DirectX 9 support and a WDDM, which is only supported in vbox 4.1.0. "Windows guests: Experimental WDDM graphics driver, supporting Windows Aero (bug #4607) and providing Direct3D support using a cleaner approach (no need to install the guest drivers in Safe Mode anymore)" Make sure you update the Guest Addition as well. –  billc.cn Aug 18 '11 at 1:18

On my Mac, the procedure for both Ubuntu and Fedora is simply to:

  1. Install Guest Additions
  2. Make sure it has enough RAM
  3. Enable 3D acceleration
  4. Bump the video memory up to 32 MB (per something I read, I think on Fedora's website—I didn't try anything less, as that worked without bogging down OS X).

Presumably, this should work with Mint as well. I don't know if any extra setup is required on Windows.

share|improve this answer
1  
Thanks @Gareth—a lot easier to read now. –  zpletan Sep 18 '11 at 14:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.