Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Ubuntu, how can I make Quanta Plus the default editor for PHP files?

In Windows we just use the open with context menu the first time for any new types of files and check use this application for these type of files. After that the files always open up in checked application. I want to know if Ubuntu has a similar feature.

Also, if I open 2 PHP files then two instance of Quanta Plus opens up. How can I get the secondary PHP files to open on another tab instead?

share|improve this question
    
see my answer on this related question for alternatives to Nautilus' built-in "open with" feature. (setting a default with Nautilus never works for me.) –  quack quixote Jun 23 '10 at 19:56
add comment

2 Answers 2

Have a look at /etc/gnome/defaults.list and look for PHP and change it with quantaplus and restart your X session.

If it doesn't have php entry, Try this.

  • Right click on any PHP file and navigate to Open With tab.
  • Add Quanta application using add button at the bottom
  • After adding it , select it from option.
share|improve this answer
    
PHP not found in /etc/gnome/defaults.list, currently it's open in gedit by default –  diEcho Jun 23 '10 at 13:17
    
each time i have to select it through option? i want to escape from that sir –  diEcho Jun 24 '10 at 9:04
    
No, Not every time, just one time. After that file manager make that as a default one :) –  ukanth Jun 24 '10 at 12:08
add comment

If you open a folder with a PHP file, then you can right click on the file and select "Open with other application ..." This will give you a dialog box where you can select the quantaplus editor. Make sure you tick the checkbox at the bottom of the dialog box which says 'Remember this application for "PHP script" files'.

share|improve this answer
    
@ Hamish there is no checkbox at bottom.... Remember this application for "PHP script" files –  diEcho Jun 23 '10 at 13:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.