Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I use shutdown -r or shutdown /r my Windows computer doesn't restart. I think this command is disabled. How can I enable this command in the command prompt?

share|improve this question

migrated from stackoverflow.com Jun 23 '10 at 17:35

This question came from our site for professional and enthusiast programmers.

    
Neither are valid: try 'shutdown /r' or 'shutdown /t 10' –  stuartd Jun 22 '10 at 15:46
    
sorry that is a type wrong . (edit the post) sry a lot –  Eva Jun 22 '10 at 15:50
    
Windows XP, Vista or 7 and which flavor (32-bit, 64-bit, Ultimate, etc)? –  glenneroo Jan 28 '11 at 17:22

2 Answers 2

Run regedit (Start -> Run) and check these registry keys if NoClose is set:

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ Explorer
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\ Explorer

0 indicates shutdown is enabled.
1 indicates shutdown is disabled.

If the value is not there, you could try adding it and setting it to 0. You'll probably need to restart as well.

share|improve this answer

I prefer SysInternals PSSHUTDOWN, has lots of options. http://technet.microsoft.com/en-us/sysinternals/bb842062

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.