Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded and extracted the contents of Virtual Box Portable from but I get the error below when launching portable virtual box. What can I do to fix this error?

VirtualBox - Critical Error

Failed to create the VirtualBox COM object.
The application will now terminate.

Callee RC: REGDB_E_CLASSNOTREG (0x80040154)


I have .net frame work 2.0 and 3.5 installed alt text And whenever I try to install 3.5 I get this error: alt text

alt text

share|improve this question
Is your user in the PC's local Administrator's group? I installed Portable VB specifically because we don't have Admin access to our machines, but it would appear that Admin rights are still required to do the initial DLL registration. Without it, it fails! – user405049 Jan 6 '15 at 17:58
up vote 2 down vote accepted

What version of .Net does the computer you're trying to run this on have installed? If possible, I would installed the latest versions

Basically, what this error is telling you is that the program requested a class from the registry, which makes me think there's something that is not installed on the computer that's required to run Virtual Box Portable.

Did you ever get to the "Portable-VirtualBox *** Extract and/or Compress ***" window?


Okay, next thought - it looks like you're running Windows 7. Do you have UAC disabled? VirtualBox is probably trying to register a COM object with the OS, and without administrative permissions, it won't be able to. I would try running the portable exe as an administrator (right-click -> Run as administrator) or, if it's disabled, enabling UAC and see if that helps.

share|improve this answer
yup,I already got d portable virtual box folder – soul Jun 24 '10 at 13:41
@Nrew updated my answer with a new thought. – Jared Harley Jun 24 '10 at 14:43
yeah you are right, Ive disabled the uac because its really annoying.Thanks it works now – soul Jun 25 '10 at 1:33

jus turn on the windows feature jus goto control panel > Add remove program > turn windows features shown on left > tick the .net3.5 checkbox then ok u r done

share|improve this answer
its enabled but still wont work, see the screenshots – soul Jun 24 '10 at 13:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.