Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7, in "Power options", the "minimum processor state" is set to 5%. Because of this, some programs are really slow. For example when I compile source code, the compilation time (Delphi 7) is 5.2 seconds. If I set minimum processor state to 100% the compilation time is 3 sec. However, I have a Intel CPU so when minimum processor state is set to 100% the CPU overheats and laptop's cooler starts to "scream".

How can I make the CPU to switch from "minimum processor state" to "maximum processor state" much much faster?

share|improve this question
    
This is not an Intel problem as AMD does the same thing thus should show the same behavior, I think it differs more based on the processor you have. I had a T7500 and it didn't seem like a problem to me, I now have a i7 720QM and that doesn't show the problem either... Btw, thank you as I discovered that my minimum processor state was set to 5% instead of 0%. (I don't think they wrote it in such way that 0% slows down, if so I can still increase) –  Tom Wijsman Jul 4 '10 at 22:21
    
But my Delphi never acted like that on my old AMD CPU. –  Altar Jun 1 '11 at 21:42
    
Well, older processors work differently as they have no power management... –  Tom Wijsman Jun 1 '11 at 23:20
add comment

2 Answers

There will always be some delay in ramping up the CPU performance. What you gain in power savings and not overheating you lose in the transition from a lower cpu speed to a faster one.

Instead of running at 100% minimum all the time you could go to something like 70%. This would likely be a fair compromise where overheating wouldn't be too much of an issue and you would get a faster compile. It's also nice to see someone's still using Delphi besides myself. ;)

share|improve this answer
    
There's quite a few of us Delphi users out there still. Plenty at StackOverflow. –  afrazier Jun 24 '10 at 21:03
add comment
up vote 0 down vote accepted

(partial) Solution 1.
Setting the "minimum processor state" to 80% decreases the time to 4 seconds. But the CPU still overheats (80% is pretty much). This is a good lesson (learned the hard way) about choosing CPU manufacturer for laptops :(

Update/(partial) Solution 2.
To fix this Intel/Windows bug, create several power profiles and manually switch between them.

Update/(full) Solution 3:
I have uninstalled Windows 64 bits and installed Windows 32. The problem is gone now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.