Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, I found if I enter a single word query "blah" into a browser (Firefox or Safari) on my home Windows machine (not connected to domain) then search is redirected to Bing, instead of my default search engine Google.

I've suspected that it is not problem of the browser, but rather hostname resolving "feature". So, I've tried

> ping blah

and it outputs

... blah.mshome.net [207.46.31.61] ...

Whois on the IP said:

OrgName:    Microsoft Corp
OrgID:      MSFT
Address:    One Microsoft Way
City:       Redmond
StateProv:  WA
PostalCode: 98052
Country:    US

NetRange:   207.46.0.0 - 207.46.255.255

When I checked the communication between the browser using Wireshark, I've got following:

Request to 207.46.31.61:

GET / HTTP/1.1
Host: blah
...

Response:

HTTP/1.1 302 Found
Cache-Control: private
Content-Type: text/html; charset=utf-8
Location: http://www.bing.com/search?q=blah&form=MSSRPD
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Date: Fri, 25 Jun 2010 23:20:03 GMT
Content-Length: 166

<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.bing.com/search?q=blah&amp;form=MSSRPD">here</a>.</h2>
</body></html>

This is quite annoying. It seems to me, that Microsoft tries hard to force user to use Bing (e.g. recent issue with Bing toolbar).

Could anyone help?

share|improve this question
    
Are you sure this is not your ISP's DNS servers? Who is the ISP? What are you DNS settings? –  heavyd Jun 26 '10 at 0:06
    
DNS IPv4 were ok. But I found that DNS IPv6 was causing the problem. –  TN. Jun 28 '10 at 19:38
add comment

2 Answers

up vote 3 down vote accepted

I found the answer: In case you have the same problem, go to registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters and empty the mshome.net value from the ICSDomain key, then disable and re-enable your network adapter.

UPDATE: After few days, it stopped working again. I've found that IPv6 DNS is also redirecting to Bing. I don't know, where Windows get the IPv6 DNS since my DHCP server is not providing that and I have not set up that. So, I've disabled IPv6 for now and it works.

share|improve this answer
    
disabling ipv6 did the trick –  Janco Dec 16 '11 at 8:01
add comment

Try setting your DNS to Google Public DNS. The IP addresses are 8.8.8.8 and 8.8.4.4
To do this go to your network adapter properties. Click on "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties". Then fill in the "Preferred/Alternate DNS Server" boxes after checking "Use the Following DNS Server Addresses".

Here is a picture of it on Windows 7:

DNS Settings

Alternately you could set the DNS settings on your router, but this would be router specific.

Here is a link to Google's discussion of how they handle nonexistent domains.

share|improve this answer
    
Thx, but this was not caused by IPv4 but rather by IPv6. –  TN. Jun 28 '10 at 19:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.