Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried to search for solution to this,
I've upgraded to the latest version of VirtualBox (3.2.6)
I'm using Ubuntu 10.04 Lucid Lynx.
I've installed Windows 7, and it detects a
"Multimedia Audio Controller" (you gotta love those amazing descriptions)
How do I make it detect that controller?

share|improve this question

2 Answers 2

I am assuming you are running Windows 7 as the guest OS, because it's not very clear from your question. You need to select Windows DirectSound and ICH AC97 as the Audio controller in the VM's Audio settings, and then you have to install the Realtek AC97 Drivers from Realtek's website.

Here is a thread on the Virtualbox forums with the same problem.

share|improve this answer

This worked for me, Windows 7 guest on Ubuntu 10.04 host:

from VirtualBox Website

In Control Panel - System and security - Windows Update: On the left side, manually select 'Check for Updates'.

Under 'Optional Updates', will be a 'Recommended' item, 'Microsoft Driver Update for Intel(r) 82801AA AC'97 Audio Controller'.

Select this from the list, and install it.

After this, the sound was skipping. this was fixed by unselecting the "Enable Nested Paging"

settings > system > acceleration > enable nested paging

Good Luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.