Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried the approach in http://superuser.com/questions/89527/how-do-i-tell-spotlight-not-to-index-a-particular-folder but it still indexes my SD card when I reinsert it into my card reader.

How do I stop this, either for all SD cards or for a particular one?


edit: It looks like I can do this either with that method or with mdutil, but I also need to delete all the hidden dotfiles (.Spotlight-V100 .Trashes ._.Trashes and .fseventsd) from the SD card -- this is for my Garmin GPS and the GPS somehow doesn't like the dotfiles.

When I delete those dotfiles, Mac OS X forgets that I have disabled Spotlight on the card.

share|improve this question

See this site for the simple answer: create a file named .metadata_never_index in the root of the volume (once it is mounted).

share|improve this answer
    
I believe he doesn't want any dotfiles on the external drive. – ghoppe Jun 28 '10 at 21:16
    
Maybe one empty dotfile is better than several non-empty ones? The files he mentions are non-empty... – Henno Jun 29 '10 at 4:47
    
Maybe. Couldn't hurt to try I suppose :) – ghoppe Jun 29 '10 at 16:03
    
I'm not sure how to deal with the issue... it's a moot point (for now) since I reformatted the card on a PC and haven't touched it with my Mac. – Jason S Jul 7 '10 at 20:48
    
Hmmm. This answer only prevents the .Spotlight-V100 directory, not the other dotfiles (.fseventsd, .Trashes ._.Trashes). – Jason S Jul 17 '10 at 13:03

As far as I know, there is no easy way to do this. But there is a utility that can prevent these files from being written called Blue Harvest.

Edit: Here is a free solution called Hidden Cleaner.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .