Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Seagate external 2TB USB drive that when I leave it plugged in, the Autoplay dialog asking what to do with the drive pops up about once every 30-60 minutes. No matter how many times I tell it to go away, it keeps coming back.

I have tried multiple power supplies, USB cables, and all the USB ports on my machine...but it keeps doing the same thing.

Also, this does not happen with the same drive on a different computer.

Could this be some power or configuration setting that is causing this?

I'm running Windows 7 x64 (the computer it works on is x86)

share|improve this question

5 Answers 5

Autoplay was constantly popping up when I have tried to watch movie from my new USB external disc connected to USB 3.0 port. I checked out all solutions from changing autoplay settings, USB root Hub settings in "Device manager", power settings, changing registry and nothing helped me until I found one post which helped me.

This is the only solution which helped me and so far doesn't have any problems.

  1. Install new USB 3.0 drivers from Intel's web site. Here is the URL of setup exe file: http://downloadmirror.intel.com/19880/eng/USB3.0_allOS_2.1.28.1_PV.exe
  2. When drivers are installed you will get "USB 3.0 Host Controller Driver" folder in your Start Menu. There is shortcut "USB 3.0 Host Controller Utility", click on it and just check "Disable USB 3.0 power management function" check box.
  3. After that everything is working fine with. Now I can play movies from my new USB external disc 2TB. Autoplay window is not popping up anymore.
share|improve this answer

may be your computers usb port has a problem ?? did you tried different usb ports? or may be electrical problem?? i do not think it is a software problem but it can be a virus problem? or as i experienced lately if it is a fat32 format and i try to do several copying data to and from that hdd at the same time it gives error and ejects itself then aoutoplay pop up .. like your problem... (if the format of hdd is different from ntfs you should format it to ntfs)

share|improve this answer

If you go to Control Panel\All Control Panel Items\AutoPlay you should be able to control what AutoPlay options are avalible. Or you could turn off autoplay.

share|improve this answer

After modifying your auto-play settings, you need to shut down and restart your computer WITHOUT removing/ejecting your hard-drive from PC.
If you remove your hard-drive before shutting down, the modifications in the settings reset. This is a bug in Windows which keeps existing for years.

share|improve this answer

This is typically due to a power configuration option. Go into device manager and don't allow the computer to put the device to sleep!

enter image description here

If this doesn't work, try playing with the power options in Control Panel

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.