Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 3 year old Dell inspiron 6400 with windows 7 and ubuntu 9.10 dual boot. I messed up my Laptop keyboard and hence my Fn key is not working and I need it to activate the wireless whose activation combination is Fn+F2. Is there any way I can emulate the Fn key or get my wireless to start in windows or ubuntu ? My bios has an option for Fn key emulation but that only supports external PS/2 keyboards and my laptop doesn't have a ps/2 slot. Any ideas would be appreciated ..

share|improve this question

4 Answers 4

I know this is late to the party, but for Dell laptops and external KBs (as well as others I am sure) the scrollLock key sends the Fn key signal. Unfortunately for all brands this information is "hidden" where it should be broadcast.

share|improve this answer

The onscreen keyboard in Windows 7 has a 'fn' key.

simply type 'onscreen keyboard' into the start menu search and click 'Turn On-Screen Keyboard On or Off' then click 'Start On-Screen Keyboard' on the window that popped up

Then use the mouse to select 'fn' in the bottom right and 'F2' (which will appear after you click on 'fn')

Viola!!

share|improve this answer
    
I had already tried that ! None of the Fn combinations work. –  0xff0000 Jun 27 '10 at 7:37
    
perhaps fn is always on in bios, try just pressing f2. its a longshot but –  bizarrechaos Jun 27 '10 at 7:44
    
Done that. Yet no results. Any ideas ? –  0xff0000 Jun 27 '10 at 9:28
    
thats all i got for now. sorry. Ill see if i can come up with something –  bizarrechaos Jun 27 '10 at 14:54

My first suggestion was to try to remap the key to another that works, unfortunately Fn keys are not seen by the operating system. you can do your own research on Google "remap fn key" and maybe a tool there will work.

Here is my other suggestion, find another way to activate wireless. Try Start>Settings>Control panel>Network Connections and find your wireless. See if you can right click it and select enable.

share|improve this answer

Go to Dell support and download the appropriate software/driver for your wireless card. All of the wireless drivers I have seen from Dell have software support to enable/disable the wireless radio from a system tray program.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.