Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my W7 MSN (windows live messenger) keeps appearing in my task bar.

I unchecked "Automatically run WLM when I log on to Windows" in the Options but it still keeps to appear.

I dont want to uninstall it but I want it to run only when I run it from Start Menu and disappear when I click Quit.

Is it possible?

Windows Live Messenger Version 2009 (build 14.0.8117.416) on Windows 7 - x64

share|improve this question
add comment

4 Answers

up vote 5 down vote accepted

Go to C:\Program Files\Windows Live\Messenger and find msnmsgr.exe. Right click it and go to properties. Go to the compatibility tab and check "Run in compatibility mode for:" and select "Windows Vista". Messenger should now display properly and act like you want it to.

If unchecked, it will remain in your task bar, even when you told it to quit.

share|improve this answer
    
That might work too, since Windows Vista didn't have the Awesome Bar. –  Ivo Flipse Jun 28 '10 at 10:39
    
not just might. it works –  Boppity Bop Jun 29 '10 at 22:18
    
@Bobb Good it worked for you! :D –  BloodPhilia Jun 30 '10 at 6:40
add comment

There are two things happening here:

  • first, if it's pinned to your taskbar it will always be visible, but if you ALT+Tab it won't pop up, since it's not active.

  • second, if your logged in, Live Messenger will always keep a dummy screen open, because they no longer use a System Tray icon (like on Windows XP). When you ALT+Tab it will always pop-up and there's no way to disable this (without any hacks).

However this second behavior has been removed in the new Beta version of Live, so your easiest solution is to upgrade to that.

share|improve this answer
add comment
  1. Open up the start menu and type in "msconfig"

  2. Press "control" + "shift" + "enter" to launch as admin

  3. Then navigate to the startup tab and uncheck the Windows Live Messenger entry.

  4. Reboot

That will stop startup, then use run it in compatibility mode like suggested below to make it act how you want it to as to closing the program

share|improve this answer
add comment

Well, if you remove manually MSN from startup, when you launch it, it will put it back to startup.

So, you have to do it in that way: sign in, go to tools > options and uncheck the option to run in startup. It will function until next MSN update.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.