Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on Snow Leopard and when I put the machine to sleep and then wake it up, I often find that it won't connect to my home wifi network any more. Thing is, I can see the wifi network, but when I try to select it to connect I get prompted for a password. When I enter the password it thinks for a bit and then tells me it can't authenticate (it's definitely the right password!). Before the sleep I was connected fine. My home wifi network uses WPA2 and I have it set as my only preferred network and to reconnect automatically if it drops.

The problem is a bit sporadic. On occasions waking it from sleep (by pressing the space-bar on the keyboard) results in it automatically reconnecting to my home wireless network. I'd say this happens one time in about five.

To fix it I usually have to either: disable and re-enable the Mac mini's wireless adapter (occasionally works), re-boot my router (usually works) or reboot my Mac mini (always works).

EDIT: The router is a Netgear DG834G.

What's going on here?

EDIT: I've a feeling this is a router thing. Something like: putting the Mac to sleep doesn't inform the router in any way so that when the Mac wakes, the router is confused because another device is trying to use the same IP address (I specify a fixed address for my Mac). Does that sound likely?

share|improve this question
Hello. Be sure to include your router information as well. – fideli Jun 28 '10 at 12:35
Thanks, I've edited to include that. – Ben Jun 29 '10 at 8:22
I have a different router, but I have noticed the same problem. – kiamlaluno Aug 21 '10 at 7:20

For context, your model(identifier, e.g 3,1) would help as well, I'd think its not the most recent one, and you couldn't be using an ancient powerPC one(not supported by snow leo) but if there was a known issue for a specific model that would help explain things. I'd use an app like Kismac to find out what neighboring networks may be broadcasting on the same channel as yours, and leave activity monitor or top up while going to sleep to see if there's some type of discrepancy between when it is and is not successful. Besides that, just for kicks try to see if the issue occurs in other users, and of course if you had another bootable operating system that you could test with that would help isolate a hardware issue as well(although it wouldn't rule out firmware being a problem).

share|improve this answer
I guess that means I'm on 1,1? Have tried Kismac - nothing on the same channel as me (13). I'll try leaving Activity Monitor on. What's 'top up' BTW? – Ben Aug 19 '10 at 19:06
Please remove your serial number from your comment, it's not a good idea. Your UUID is totally random, and the rest is generic, so except for that you're safe. CoreDuo(instead of Core2Duo) would mean you're not 802.11n capable, but neither is your router. 'top' is a binary(application) that runs in a shell when you launch Terminal(it's located in /usr/bin/top) and has similar usage to activity monitor. I'm not sure why I also didn't mention opening /Applications/Utilities/Console and check the logs for anything around the time of failure. – Sacrilicious Aug 29 '10 at 2:47
Thanks, I deleted my comment (couldn't see a way to edit it). Console was the first thing I tried but I couldn't see anything strange in it. I've actually just found a workaround so I've posted an answer... – Ben Sep 4 '10 at 6:28
What's the danger with giving away my serial number BTW? – Ben Sep 4 '10 at 6:29
up vote 0 down vote accepted

Well, after many months of messing around I found a solution. More of a workaround really. I bought an LM Tech USB Nano 802.11N dongle, disabled my Mac Mini's internal Airport adapter and enabled the LM Tech one.

Now, every time I wake my Mini from sleep the USB dongle 'wakes up' too and the wireless connection is immediately re-established. I've never been very impressed with the range and robustness of the Mini's Airport card and now, even though I had to buy something (something very cheap in fact), it seems to be sorted! What a relief.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .