Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen different ways to turn off the annoying Ubuntu beep but what is the best way to turn it off permanently through software?

share|improve this question
    
What is the Ubuntu beep? –  innaM Jul 30 '09 at 15:43
    
the noise the pc speaker on system error –  Craig Angus Jul 31 '09 at 15:05
    
system error ? –  innaM Jul 31 '09 at 21:13
add comment

4 Answers

up vote 9 down vote accepted

disable the warning beep you can do so by editing your /etc/rc.local file. Open the file in your editor of choice and go all the way to the bottom of the file. At the bottom there should be a line which reads exit 0. Add a new line directly above this one and put this on that line:

modprobe -r pcspkr.

Save the file and this will turn off the system beep. If you want to turn the system beep back on, just edit this file again and remove the line that was added.

(OR)

You can disable this by editing a file and entering two simple lines.

gedit /etc/modprobe.d/blacklist

And then add:

silly speaker beep

blacklist pcspkr

Save your file and the speaker beep will be gone when you reboot.

If you don’t want to wait until a reboot, simply type:

sudo rmmod pcspkr

(OR)

You can disable system bell if in the Terminal you go to Edit->Current Profile->General and uncheck the Terminal Bell Or in the Configuration editor go to apps->Gnome-Terminal->Profiles->default check silent Bell.

(OR)

Edit the .inputrc file in your home directory (create it if needed) and add the line

set bell-style visible

You can also add (or uncomment) this line in the general /etc/inputrc file to set the bell-style for all users (overriden in ~/.inputrc).

share|improve this answer
    
This also works: xset -b –  teabot Feb 12 '10 at 11:53
    
Is that period "." supposed to be at the end of "modprobe -r pcspkr"? –  Bort Nov 30 '13 at 0:48
add comment

Disconnect the PC speaker inside the Chassis.

That is the simple answer.

share|improve this answer
    
Why the downvote? This solution works! I have even done this one myself a time or two. –  Axxmasterr Jul 31 '09 at 13:45
add comment

Check out this answer over on serverfault

Disconnecting the speaker works too ;)

share|improve this answer
add comment

The best way is to disable the pcspkr driver, that way you don't have to undo any hardware changes in the future. Open up a terminal and enter the following:

sudo modprobe -r pcspkr

Then, if you want to avoid doing this every time after rebooting, append the following line to your /etc/modprobe.d/blacklist file. If it's not there, create it.

blacklist pcspkr
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.