Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a PC with Windows 7 Home Premium 64bit and a laptop with the same.

I have a Windows 2003 virtual machine, created in VMWare Workstation, running on the laptop. The VM currently uses NAT (If I switch to Bridged, without making any other changes, the VM cannot see anything).

From within that virtual machine, I can ping my PC. It gives results similar to this:

c:> ping marc-pc

Pinging marc-pc.localdomain 192.168.1.101 with 32 bytes of data
reply from.... 

And all seems well.

When I run ipconfig from CMD on the laptop's VM, I get:

Connection-specific DNS suffix: localdomain
IP Address ... 192.168.239.129
Subnet Mask ... 255.255.255.0
Default Gateway ... 192.168.239.2

So, from my PC, if I try to ping 192.168.239.129

I get "Request Timed out".

Basically, the VM on the laptop can ping the PC, but the PC can't ping back.

How do I set up the VM on the laptop so that the PC can communicate with the VM?

Thanks!

share|improve this question
    
What kind of network do you have setup in VMWare? Bridged, host only? –  RussellW Jun 28 '10 at 17:17
    
Thanks Russell. I updated the description to indicate I'm using NAT. Please know that I know very little about networking! –  Marc Esher Jun 28 '10 at 17:36
add comment

2 Answers

up vote 1 down vote accepted

Since you are using NAT, you will want to set up port forwarding as Chris instructed. See the link below for details.

For starters, your VMWare Workstation network has established 192.168.239.2 as a gateway, with IPs assigned in the 192.168.239.X block. You will probably want to set the VMWare guest to have a static IP so that port forwarding is not broken if the guest renews its IP from the VMWare workstation network controller. Check the Windows 2003 help guides for setting up a static IP. Just be sure to use the gateway address (192.168.239.2) in the settings, as well as for the DNS. This way, your guest will check with VMWare Network controller and route any commands to your host PC. You are seeing this when you ping from the guest to the host. If you run this command in the guest, you will see the path it takes:

traceroute marc-pc

or

traceroute superuser.com

Configuring NAT on VMWare Workstation http://www.vmware.com/support/ws5/doc/ws_net_nat_advanced.html

share|improve this answer
    
thanks Russel and Chris! –  Marc Esher Jun 30 '10 at 11:47
add comment

Your NAT is probably set to allow traffic out but not to allow traffic in. Somewhere on VMware there is an option to manage virtual networks which will allow you to configure your NAT. From there I believe you can enable port forwarding through the NAT for various services that can get you out. I haven't used workstation in awhile, but if you find out where to edit your NAT settings you should be fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.