Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The keys for volume control (i.e. volume up/down/mute) aren't working right now - along with a few other things. For example the "About My Mac..." menu entry doesn't work. And also, the system settings dialog loads fine but when I click on the sound settings, it crashes/freezes. Audio itself works fine though, I am just right now playing some music in iTunes.

I'm quite sure it would work again after a restart or even a relogin and that the process which is responsible for it just crashed.

Though, I am curious, what process is it? Does someone know? (And then I maybe would just restart that process instead of my whole machine -- everything else is fine and I hate restarts.)


I also looked at the Console logs and every 10 seconds, I am getting this entry:

28.06.10 22:32:46 com.apple.launchd.peruser.501[156] (net.infinite-labs.PlugSuit.Agent) Throttling respawn: Will start in 10 seconds
28.06.10 22:29:56 com.apple.launchd.peruser.501[156] (net.infinite-labs.PlugSuit.Agent[86943]) posix_spawn("/Users/az/Library/PreferencePanes/PlugSuit.prefPane/Contents/Resources/PlugSuit Agent.app/Contents/MacOS/PlugSuit Agent", ...): No such file or directory
28.06.10 22:29:56 com.apple.launchd.peruser.501[156] (net.infinite-labs.PlugSuit.Agent[86943]) Exited with exit code: 1

I wonder a bit what that is (I guess something I have installed at some time, don't remember anymore, at least a year ago) and why that is causing troubles right now.


Those who wondered about the WLAN symbol (what I have written earlier, where I initially thought it might be related), this is what I have found in the Console:

28.06.10 13:54:24   airportd[82188] [most time: (2.651557) _scan] trace: <CFArray 0x100102840 [0x7fff70939f20]>{type = mutable-small, count = 9, values = (
    0 : <CFString 0x10003acb0 [0x7fff70939f20]>{contents = "pref_netwk_AJ"}
    1 : <CFString 0x10003ab70 [0x7fff70939f20]>{contents = "scan non-DFS channels"}
    2 : <CFString 0x10010f550 [0x7fff70939f20]>{contents = "(2.651557) _scan"}
    3 : <CFString 0x100111280 [0x7fff70939f20]>{contents = "(0.000011) _lookup"}
    4 : <CFString 0x100110cf0 [0x7fff70939f20]>{contents = "(0.090089) _association"}
    5 : <CFString 0x10003ab90 [0x7fff70939f20]>{contents = "scan non-DFS channels again"}
    6 : <CFString 0x100502cf0 [0x7fff70939f20]>{contents = "(1.470134) _scan"}
    7 : <CFString 0x100501820 [0x7fff70939f20]>{contents = "(0.000009) _lookup"}
    8 : <CFString 0x10050cf90 [0x7fff70939f20]>{contents = "(0.408480) _association"}
)}
com.apple.message.domain: com.apple.airport.autojoin.summary
com.apple.message.signature: AutoJoinSuccess
com.apple.message.result: success
com.apple.message.value: 4.722627
com.apple.message.value2: 5.000000
com.apple.message.value3: 1.000000
com.apple.message.uuid: E637229A-E004-44C8-9F8B-0845B23CD93D

Ok, after killing randomly some other processes, I made my system mostly unuseable so I were forced to restart. I still see the errors about PlugSuit every 10 seconds in the Console log. Although just everything works right now -- I would not even know about that PlugSuit if I wouldn't have looked into the Console.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I'd guess either BezelUIServer or coreaudiod.

share|improve this answer
1  
I was leaning this way, too, until I realized that WLAN is a part of it -- this issue seems centered around the menu bar much moreso than the screen overlays or actual Core Audio services. –  John Rudy Jun 28 '10 at 18:38
    
I think WLAN was unrelated. BezelUIServer really much seems like it is that (from the description). But I didn't found a way to restart it. Do you know any? I restarted coreaudiod (just killed it and it restarted itself) but that didn't changed anything. –  Albert Jun 28 '10 at 21:14
add comment

I can't prove it, but I suspect this will be the domain of SystemUIServer, as the issue seems to revolve entirely around the menu bar.

I'd check your Console logs for any issues, and consider rebooting to bring the process back online correctly.

Update based on the new information:

I suspect PlugSuit is your real problem. Based on the site, it seems to manage extenders to the Mac OS X system. You'll probably want to disable all of those extenders and remove PlugSuit, particularly since your tags indicate that you're on Snow Leopard, and there's a huge red warning on the site that Snow Leopard is explicitly not supported.

share|improve this answer
    
I killed SystemUIServer and OSX automatically restarted this process. This restarted the symbols in the top bar (they disappeared and appeared immediately again). This didn't really changed any of the described behavior, the about-my-mac menu entry still doesn't work and also not the volume keys. (WLAN seems unrelated, the symbol went ok already before.) –  Albert Jun 28 '10 at 20:28
    
It was a good hint to look at the Console logs. There seem to be some related issues in the logs. See my question, I extended it. –  Albert Jun 28 '10 at 20:30
    
See my update to the question: The PlugSuit error seems unrelated. Though, I tried to uninstall it but the description doesn't work (it doesn't give me the remove option in the installer and system settings also doesn't show it). And the link to the Afloat update is dead. –  Albert Jun 28 '10 at 21:06
    
See here for details about uninstalling PlugSuit: superuser.com/questions/157863/macosx-how-to-uninstall-plugsuit –  Albert Jun 28 '10 at 21:12
add comment

Do you have the PlugSuit prefpane installed? The first group of messages seems to come from that. Their webpage claims it isn't compatible with 10.6 and has instructions for removing it. Resolve that issue first, then see if you still have a volume-control issue. There may be more than one thing going on here. Or this process may be taking something else down with it.

share|improve this answer
    
It seems unrelated (still get the errors after a restart -- everything else works fine). I tried to uninstall it but their description doesn't work, see here: superuser.com/questions/157863/macosx-how-to-uninstall-plugsuit –  Albert Jun 28 '10 at 21:13
    
Then it's time to contact their tech support (invitation on that same page) and get it resolved. At the very least, it's clouding the issue, and quite possibly is the issue. At any rate, having a dying process thrashing around every 10 seconds isn't doing your system any good. –  JRobert Jun 28 '10 at 21:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.