Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got BSOD while attempting to uninstall a program in Win XP, so I tried to reinstall the OS (because the guy who gave me the pc wants a clean-up) but a STOP 0x0000007F (0x00000008, 0x80042000, 0x00000000, 0x00000000) occurs.

I tried then to boot Kubuntu 9.04 live cd, and it booted fine, but when I tried an installation it failed too: just crashing...

I tried to change the RAM and the hard drives to no avail.

I'm thinking that it's an hardware failure, but can't track it down: what could it be? Video card? Motherboard?

Any advices?

EDIT: I ran 7 successful memtest - not even an error. I have to look at the harddisk ribbons and the motherboard.

EDIT No.2: I tried another harddrive, switching to sata connectors to no avail: the sata harddisk it isn't even recognized...Can it be the video card, or it will be the Motherboard?

share|improve this question
Is this a clean install attempt? – Moab Jun 28 '10 at 20:46
Not really, as it was an already XP install; I would do a clean install if I could...but those crashes/freezes/BSODs don't give me the possibility to do so. – dag729 Jun 29 '10 at 10:58
up vote 1 down vote accepted

What error did you get when the kubuntu install failed?

0x0000007f This is the link to Microsoft's explanation of that stop error.

If you have nothing else to do, try running a harddrive test from a live cd to try and make sure the drives, and their headers/cables are good as well.

share|improve this answer
When the kubuntu install failed everything I got was a freeze: I was unable to switch to any tty. Actually I have something else to do...but I'd rather try an harddrive test! :D Looking at the Microsoft KB the I understand that chances are to have a faulty motherboard. I'll test them and I'll let you know. – dag729 Jun 28 '10 at 19:06

is it a laptop? i came across a laptop that had a similar problem, and traced it to a faulty harddisk ribbon connector, something to consider anyway as laptop harddisk ribbon connectors seem quite fragile...

share|improve this answer
No, it isn't a laptop: is a desktop, but I'll take a look at the ribbons anyway. Thanks a lot! – dag729 Jun 28 '10 at 18:59

A. Be sure your XP install disc is at least SP2 integrated

B . Check your bios for a "Compatibility Mode", or other setting to slow the processor down while installing the OS, once the OS is installed (hopefully), set it back.

Your First Parameter of the bug check = 0x00000008, or Double Fault, indicates that an exception occurs during a call to the handler for a prior exception. Typically, the two exceptions are handled serially. However, there are several exceptions that cannot be handled serially, and in this situation the processor signals a double fault. There are two common causes of a double fault:

  1. A kernel stack overflow. This overflow occurs when a guard page is hit, and the kernel tries to push a trap frame. Because there is no stack left, a stack overflow results, causing the double fault. If you think this overview has occurred, use !thread to determine the stack limits, and then use kb (Display Stack Backtrace) with a large parameter (for example, kb 100) to display the full stack.

2 . A hardware problem.

Note: A double fault can occur when the kernel stack overflows. This overflow occurs if multiple drivers are attached to the same stack. For example, if two file system filter drivers are attached to the same stack and then the file system recurses back in, the stack overflows.

share|improve this answer
Given that I had freezes also with a GnuLinux live cd, can we exclude the #1 kernel stack overflow? Anyway, I updated my question, with the latest hardware tests. – dag729 Jun 29 '10 at 11:01
What make and model PC is it? – Moab Jun 29 '10 at 12:47
It was assembled: MotherBoard ASRock 775v88+, CPU Intel Pentium 4 3GHz. – dag729 Jun 29 '10 at 14:29
Did you replace the ribbon cables? – Moab Jun 30 '10 at 5:00
Yes, I'm editing the question while I'm going forth on the tests. No luck with the ribbons... – dag729 Jun 30 '10 at 22:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .