Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I double click on the .PDF, files I can open them with Foxit PDF reader, but the icon is wrong (I have the icon of the unknown files). How I can fix this problem?

share|improve this question
add comment

4 Answers 4

up vote 0 down vote accepted

Try rebuilding the Windows 7 icon cache.

  • Open up a Command Prompt (Start -> cmd)
  • Run:

    del /ah "C:\users\YOUR_USERNAME_HERE\appdata\local\iconcache.db"
    
  • Reboot
share|improve this answer
    
didn't work. any other ideas? –  Alex Jun 28 '10 at 19:08
    
Try going into properties then where it says Opens with: choose foxit again and hit apply. Does the foxit program have the right icon under Program Files? Maybe try reinstalling foxit? –  John T Jun 28 '10 at 19:39
add comment

I found the solution to this problem. I am running Windows 7 64-bit and using the 32-bit Foxit Phantom software.

When the program is installed, the default registry entry for the program icon in:

HKEY_CLASSES_ROOT\FoxitPhantom.Document\DefaultIcon

is:

"C:\Program Files (x86)\foxit software\foxit phantom\Foxit Phantom.exe"

Apparently Windows 7 64-bit needs the additional icon reference number if an icon is stored in an .exe (as in this case) or other icon containing files. The correct value for the registry key to correctly display Foxit Icons is:

"C:\Program Files (x86)\foxit software\foxit phantom\Foxit Phantom.exe,-128".

After saving and rebooting, the correct icon should be displayed.

share|improve this answer
add comment

I had the same problem, however it turned out the icons weren't actually the icons of unknown files but thumbnails of the first pages of the documents (PDF and other).

To make it show normal icons:

  1. open Windows Explorer and click on Organize → Folder and Search Options
  2. go to the View tab and check the "Always show icons, never thumbnails" option
  3. click OK
share|improve this answer
add comment

TO make it easier, use xnview context menu to convert a downloaded png foxit icon to ico and put it in the FoxIt Reader folder. you'll notice in the folder that Foxit Reader.exe doesn't have an icon either. Right click on the exe file, go to Properties, choose Change Ico, direct it to the ico file you just put there and that's it. No registry tampering.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.