Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have successfully used the Windows 7 XPS Document writer for quite a while under windows 7 (64 bit).

Now however when i try to print i get prompted twice for the output file name and then get different error messages depending upon the application being used. e.g. Notepad gives a 'The I/O operation has been aborted because of either a thread exit or an application request'.

I have disabled and reenabled the XPS facilities of windows features and have similiarly removed and readded the printer. But the end result is the same.

I've uninstalled all applications i have installed since the time when i know it worked but this also has not made any difference.

Suggestions please!

share|improve this question

I think it's pretty simple, because I was having the same issue and fixed it. I have the same OS and XPS worked for a while, then suddenly stopped working.

Here is what you need to do:

  • Go to Devices and Printers
  • Select XPS printer and right-click
  • From the options, select Troubleshoot.

Then the system will apply the necessary fix and set XPS to 'Default printer'. At this point, it is up to you to go with this preference. Once it's fixed; select XPS printer and right click and select 'Printer Properties' and perform 'Print a test page'.

share|improve this answer

There's an XPS downloads page. There's the Microsoft XPS Essentials Pack which includes the software for generating XPS document.

You could try reinstalling that.

share|improve this answer
thanks - unfortunately the windows 7 option states "Windows 7 XPS Viewer is already installed on your system." with no option to download to reinstall. – jamie Jun 28 '10 at 20:06
@jamie - that's unfortunate. I was hoping there'd be a "repair" option at the very least. – ChrisF Jun 28 '10 at 20:28
in the end i have ended up re installing windows 7-problem sorted. – jamie Nov 7 '10 at 11:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.