Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server that acts as dhcpd, and an linksys AP(with dd-wrt) connected to it via ethernet.

I didn't want the AP to act as an router (as the server does that), so I've set it up as an Wireless Access Point.

However, while I can connect (i.e. associate and authenticate) via wifi to the AP, there is no connection to the server (since I can't get an ip address).

When I connect via a cable via the AP, it works, as it acts as a switch.
All interfaces (except loopback) on the AP are bridged together.

My question is, what could be the cause of my problem? (the lack of connection over wifi)

share|improve this question

I had a similar problem, but in my case I had the DNCP server on the router. Anyway, I had to uncheck [deselect] the following options on the Network Address Server Settings (DHCP) screen:

  • Use DNSMasq for DHCP
  • Use DNSMasq for DNS
  • DHCP-Authoritative

After I turned them all off, my clients where able to get an IP address from the DHCP.

Also, try to disable the wireless security completely and test the connection. If you suddenly can connect that means that you had the wrong wireless security settings. Remember to turn wireless security on and configure it properly.

share|improve this answer

Is the problem that you are not getting an IP over wireless? If you set a static IP on your device within that network you can still contact the router? Also do you mean all interfaces besides the WAN port are bridged together?

It sounds like DHCPD is not broadcasting over the bridge you setup (probably br0). From the webpage you could go to setup, networking, multiple dhcpd servers, click add and create one and choose its interface to be br0.

Also you might want to go to setup, vlans and scroll to the bottom of that page and make sure the wireless box is set to LAN. I think from the web-gui this puts the radio on the LAN bridge.

share|improve this answer
WAN port is bridged too, and it's set to work like a LAN port (see the link in the question). And creating multiple dhcp servers doesn't make sense, because I want to have dhcpd on the server, not on the AP. I can't find any information about VLANs neither in the web interface, nor via ssh, so I guess I don't have any. And yes, the problem is that I'm not getting an IP over wireless. I've tried to set ip manually, but I still can't connect with the router. – Mewp Jun 28 '10 at 20:54
OK, I re-read your question and understand what you were getting at, I missed the part about you having an external dhcp server. Off the top of my head make sure WLAN/WiFi isolation is turned off One question, lets say your LAN is dhcp server .1 ddwrt box .2 can you set an IP address to .3 can you ping .1 or .2 ? – Chris Disbro Jun 28 '10 at 21:36
Turns out that the problem has fixed itself. I've tried pinging the router from static address, and it worked (though yesterday, when I've asked the question, it didn't). Then, I've tried obtaining address... and it worked too. So the problem had an unknown cause, and I don't know what fixed it. Thanks for the answer anyway. – Mewp Jun 29 '10 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .