Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This story starts with me taking my USB stick to work
and unplugging it by accident in the middle of a file transfer.
The USB stopped working completely, now I have Linux Ubuntu on my Laptop at home
So I tried messing around with Gparted and Fdisk and all it did
Was making my USB stick be partition less and 8 MB instead of 2GB
So instead of creating more havoc, I ask kindly for help.
I tried going to fdisk /dev/sdb
and inside there were no partitions, added a new one
but that didn't really do anything, /dev/sdb1 was none-existent..

share|improve this question

3 Answers 3

I had a similar problem. For some reason QTParted was able to fix it while GParted was not able to.

share|improve this answer

OK, when you connect the device are you sure the system is reading the USB stick at all? Try a

dmesg | tail

after you have attached the device and make sure you use the device that was listed in dmesg. If you are ok with erasing everything on the device (I assume you are) I would just

dd if=/dev/zero of=/dev/sd?

with ? being the letter for the USB device. This will write a bunch of zeros to the entire flash drive, erasing everything on it.

from there you should be able to fdisk or gparted into it and create a new partition.

Another question for you. Was the device first formatted with at FAT filesystem? If so it might have been marked as dirty and you would have needed to run fsck.vfat on the unmounted device or chkdsk.exe (from windows).

Let me know if you still can not get it working.

share|improve this answer
    
dmesg | tail returns sdb: unknown partition table I did the dd if=/dev/zero of=/dev/sdb and it said 8.4MB copied (why 8MB only?) –  Asaf Jun 29 '10 at 14:58
    
after you attach the device do a sudo fdisk -l what does it say for /dev/sdb? Are you able to access /dev/sdb with fdisk or gparted and write to the partition table? try umount /dev/sdb ; dd if=/dev/zero of=/dev/sdb bs=1m and see if its still reporting 8MB, can you also paste the results of that dd command? –  Chris Disbro Jun 29 '10 at 16:44

Making a new partition table is not enough, you have to format the partition with a file system. I usually use cfdisk instead of fdisk since it is a bit more user friendly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.