Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As per subject, I'm not able to map a remote network drive to my Vista. I tested on an XP machine in the same network as mine and it's able to map the said drive, I also tried another Vista in the same network, but it's not able to map as well. So it's definitely the Vista.

Anyone can shed a light on this?

EDIT: The error message was just generic Windows cannot access \\xx.xx.xx.xx\share_name

EDIT2: Ok, after the error message appears, it actually asks me whether I want to diagnose. So I did and I got this:

[Window Title] Windows Network Diagnostics

[Main Instruction] "xx.xx.xx.xx" is not set up to establish a connection on port "File and printer sharing (SMB)" with this computer.

[Windows found a problem that cannot be repaired automatically] [Cancel]

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Probably has to do with LAN Manager authentication level.

If you have the full featured Vista (access to security policy gui) follow this http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746

Otherwise you'll have to change the value in the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LMCompatibilityLevel from a 3 to a 1

This applies to Win7 machines too when trying to browse XP / Samba shares.

share|improve this answer
    
I don't have LMCompatibilityLevel and I don't have secpol.msc as well =/ any other idea? –  andreas Jun 30 '10 at 14:14
    
Ok nvm, I actually have LMCompatibilityLevel, changed to one but I'm still getting windows cannot access... –  andreas Jun 30 '10 at 14:22

Make sure the workstation service is started and set for automatice startup. This is needed to access network shares.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.