Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows XP SP3 machine. Every so often (sometimes several times a day) my keyboard (or Windows, or something) decides that it is going to translate the keys I am typing. It's always the same behavior: Specifically

  • Q and A are transposed.
  • W and Z are transposed.
  • the digit keys (the row below the F1-F12 keys) become random punctuation characters.

and several other random shuffling of keys occur. Interestingly:

  • the numeric keypad still works
  • the corruptions are always associated with a particular application. Exiting the application (e.g. Delphi, or Chrome), and restarting the app. cures the problem.
  • the same problem occurs on my laptop at home, I guess because I run the same apps.
  • Ctl-Q and Ctl-A are also transposed

I'm convinced that something I'm running is trashing something but I have no idea where to look. I'm hoping someone reads this and says "oh yeah..."

Yes, I have AV software running.

share|improve this question

3 Answers 3

up vote 5 down vote accepted

It sounds like your keyboard is switching between a UK/US setting and a French setting - known as AZERTY (as opposed to QWERTY) from the first 6 characters on the top line of letters.

The Wikipedia page on Keyboard layouts shows that the Q & A and W & Z keys are swapped in these two layouts (along with a few other keys):

QWERTY:

QWERTY layout

AZERTY:

AZERTY layout

With this information you might be able to track down the application running when the switch occurs.

share|improve this answer
    
Brilliant. I assume that I'm pressing the key combination to change the layout accidentally (or on purpose - Shift-Alt is used in the Delphi IDE editor to mark column blocks). I have removed all but 1 keyboard from Control Panel > Regional and Language Options > Languages > Details > Settings > Installed Services > I can't believe I lived with this problem for so long. Many thanks. –  rossmcm Jun 30 '10 at 15:04

Try pressing left ctrl + left shift and see if that fixes it.

share|improve this answer
    
Shift-Alt was the culprit. –  rossmcm Jun 30 '10 at 15:09

Go to Control Panel->Language and Regional->Language Tab->Details

And see if the key layout ChrisF mentioned is set up.

If it is, click on "Key Settings" and change the hot key to something less common (or disable it).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.