Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Microsoft Word 2007. I have several large screenshots that need to be inserted into the document at various places. When I paste the pictures, I have to manually resize them to fit within the margins of the document. This takes up too much of my time. I tried batch resizing the images before inserting them, so they were the right size, but it appears Word uses a higher dpi when printing, so those pictures came out blurry compared to the ones resized within Word.

So what I am looking for is if there is an option that makes Word automatically shrink large images when I paste them so that they are the width of the page (with correct aspect ratio). I'm using "in line with text," though I could use "tight" if necessary.

Again, this isn't a life-or-death thing. I could always manually resize the 30+ images. But it seems like there should be an easier way. Has anyone come across this?

(TL;DR: I'm looking for a way to automatically resize an image larger than page width to page width when pasted in Word.)

EDIT: When I try making an image 96dpi and pasting into Word, it shows up very small (but prints clearly). When I upscale it, it retains this clarity. But it still isn't pasted in as the correct size initially, which is what I'm looking for...

share|improve this question
add comment

6 Answers 6

up vote 5 down vote accepted

From Default Picture Settings :

If you have a need to format quite a few pictures using the same settings, the easiest approach is to create a quick-and-dirty macro to apply the formatting settings you want. You could then paste the picture, select it, and then run the macro. You can create such a macro by following these general steps:

  1. Paste the picture in your document.
  2. Select the picture you just pasted.
  3. Start the macro recorder.
  4. Make the size and position changes to the picture, as desired.
  5. Stop the macro recorder.

Your macro is now ready to use. Whenever a new picture is pasted in your document, select it and run the macro to apply the "default" settings.

See also Assigning Shortcuts to Macros in Word 2007 :

If you really want to get the most out of your commonly used macros in Microsoft Word 2007, you can assign buttons or keyboard shortcuts to them so that the process of running these macros is even more efficient.

share|improve this answer
1  
I had to manually write the macro, since you can't edit pictures while recording, but it worked. (code: pastebin.com/UJtukBqE ) –  NickAldwin Jul 8 '10 at 13:37
    
I couldn't resize an image when recording a Macro on the Mac version of Word 2011. –  Snow Crash Apr 2 '13 at 15:59
add comment

I find that a quicker way to do this is to just use F4 (or ctrl-y). Note that on this page it says that F4 will "Repeat the last action", but ctrl-y will also do the same thing. On the Mac version (Office 2011) F4 does not work, so cmd-y is the only option.

So, insert all your images without worrying about their size. Then right click on the first image and select "Size and Position." Set the width as desired, then click OK. Then select each of the subsequent images (left click on them) and simply press F4 or ctrl-y.

This same trick can also be used to repeatedly apply other changes or effects in the "Size and Position" or "Format Picture" dialogs to different pictures.

share|improve this answer
3  
+1 for F4! Never heard of that one before- genius! Unfortunately I don't think it works in this situation. –  outsideblasts Dec 21 '11 at 20:47
    
F4 just opened up the Dashboard on the Mac. –  Snow Crash Apr 2 '13 at 15:59
    
@SnowCrash I looked around some, and it appears that ctrl-y will also repeat the last action if there's nothing to redo (i.e. you didn't perform an undo immediately before). So, give command-y a try and see if that works on the Mac. I don't have a Mac to try it out on. –  Brandon Apr 10 '13 at 16:16
    
Cmd Y does repeat an action in MS Word on the Mac. F4 does not. –  Snow Crash Apr 10 '13 at 17:38
add comment

What I do in this case is insert one picture, resize it and set any other options I like. I then copy-paste this picture at all places in the document where I need a different picture with the same formatting. Finally I replace the pictures one-by-one using the right-click "Change picture" function of Word 2007. One snag is, that this option disappears upon saving your document in another format than docx (e.g. doc).

share|improve this answer
add comment

the macros in 2010 for images don't work. Nothing you do to an image in record mode ends up in the macro. I don't program in vbasic so this completely sucks. and paste in line with text changes nothing. way to break stuff MS!

share|improve this answer
    
It wasn't working well for me either. I ended up writing my own code. Give it a shot: pastebin.com/UJtukBqE –  NickAldwin Dec 21 '11 at 19:37
add comment

All Office 2007/2010 programs do this, but some make difference choices about the viewing DPI. But it's not actually changed, what happens is that it is just re-scaled. If you select your picture and go to Picture Tools>Format>Size and click on the little triangle in the bottom right corner, you'll see how it resized. You can click the "Reset" button to put it at actual size (which is a pixel w/h * dpi / 2.54 calculation)

share|improve this answer
add comment

Word uses 96 dpi for images so if you resize your images to the correct size based on this you shouldn't notice any blurring.

i.e. for an A4 portrait page with 1cm margins, body width is 19cm, so image at 96 dpi should be resized to 718 pixels wide (19 / 2.54 * 96)

share|improve this answer
    
Does it display the images at 96dpi too? Because when I paste the 96dpi version into Word, it shows up very small (but prints clearly). When I upscale it, it retains this clarity. But it still isn't pasted in as the correct size initially... –  NickAldwin Jun 30 '10 at 15:55
    
This solved my problems perfectly. Changed from 72dpi to 96 and it worked. –  Martin Oct 18 '10 at 12:45
add comment

protected by Community Mar 4 '13 at 6:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.