Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's been eight hours now that I try fixing my windows system. After I uninstalled ubuntu, and moved the windows seven partition to fill the space freed by the operation, I tried to fix the Windows 7 boot process by running

bootrec /fixmbr
bootrec /fixboot
bottrec /rebuildbcd

My config was detected and everything, but then I got a black screen when booting, with nothing but a blinking cursor.

Basically, I've tried everything I had known to work in such situations:

  • Startup repair (didn't work, didn't find any problem)
  • all bootrec options
  • bootsect /nt60 C: bootsect /nt60 C: /mbr, and bootsect /nt60 ALL
  • Removed the bcd file and recreated it

Here is what I noticed : removeing the bootmgr file didn't trigger any subsequent bug. I guess the loader is not even loading up to this point.

What can I do? I'm quite desperate, and I really wish not to reinstall the system... Is there a way to repare the full boot process?

Thanks!

share|improve this question
    
Start recovering your data using a Live CD before you mess the partition up too much. Good Luck –  Puddingfox Jun 30 '10 at 17:51
    
you might need to use bcdedit to fix things. –  user33788 Jun 30 '10 at 18:46
    
The 'bottrec' command completely wrecks things, didn't you know? Or maybe this is what happens when you do something like replace Linux with Windows. The interesting question: is it Windows 7 refusing to have anything to do with a machine that's had Linux on it, or Linux wrecking things so that Windows 7 has no idea what to do with it? –  Jonathan Leffler Jul 1 '10 at 0:59

2 Answers 2

Have the same problem myself. The kicker is that if I put an /nt52 bootsector in, my ntldr-boot.ini will actually boot XP (I dual boot). But when I replace that with /nt60, it hangs on the blinking cursor. It all started when I hosed my BCD and MBR + Partition table. They've all been reset/fixed, but this strange problem remains.

What I suggest (and am going to be trying to fix myself), is use the Vista/Windows 7 Recovery "Startup Repair" option and see if that fixes it. It should do the same thing as bootsect.exe and /or bootrec, but who knows, maybe Microsoft does it a tiny bit extra that might fix the problem.

The only other step would be a repair install of the OS, which seems like an awful lot of work.

EDIT: Tried the Startup Repair option, and it was able to finally fix the problem. Had to run it twice though. Once to "find" the Windows install and fix the BCD, the next time to fix the boot chain process. (Something to do with the connection between the MBR, bootsector, and bootmgr I think). Technically the bootrec.exe commands should do the same thing, but for whatever reason when you let the Startup Repair from the recovery environment do it "automagically", it must do a lil something extra special. Give it a try and goodluck :)

share|improve this answer

Be sure you have no usb storage device plugged in during boot.

Check your bios to be sure the correct HDD is set as first boot device, if there is a boot priority section, check that also.

.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.