Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to solve this and i used partimage to restore the MBR from a file. It completely wrecked my partitions. I now have 3, a 100mb, a large one and a 9mb. Windows XP complained and Windows 7 got an error trying to format on the middle drive. I then tried to install on the middle drive and it didnt allow me.

I cant install an os! how do i fix this?!

-edit-

I tried

bootrec /fixmbr
bootrec /fixboot

and

bootsect nt60 ALL /force

no luck, i still cant repartition it.

share|improve this question
    
You may have overlapping partitions or some similar conflict that Windows won't let you fix. I suggest examining the partition table from a Linux Live CD and posting what it says, or it may be obvious what needs to be done. –  kmarsh Jun 30 '10 at 21:22

2 Answers 2

up vote 1 down vote accepted

Windows must be installed on the first partition on the drive. It sounds like you have a few little partitions before it. Windows 7 and vista creates a little partition for its own use right before the primary partition where windows is installed. Either way... when you install windows... it needs the first part of the drive in order to work properly.

There are probably two little partitions now because windows 7 had one from the initial install. Now that you tried re-installing on the middle partition, it created another little partition right before it during the install process. Thus you have two little partitions.

If you want to reformat... delete the two little partitions and merge the space with the main partition (or just delete all partitions) and then install.

share|improve this answer
    
It doesnt allow me, i get an error –  acidzombie24 Jun 30 '10 at 20:40
    
@acidzombie24 Try using the gparted live cd to do the partition work. gparted.sourceforge.net –  James T Jun 30 '10 at 20:43
    
i believe i have that on my livecd. The graphics didnt work. Do you know the cmd line option? i tried googling but havent had luck ATM. –  acidzombie24 Jun 30 '10 at 20:44
    
@acidzombie24 You can try using the vesa driver if it lets you choose. Also choose 800x600 resolution. If this does not work, you can use cfdisk which is a menu based command line partition editor. Make sure to "write" before quitting. Let me know if you need more details. –  James T Jun 30 '10 at 20:51
    
cfdisk worked! however i found an odd problem. Win7 allowed me to partition the drive. WinXP complained and didnt allow me to get to the menu where it ask if i like to repair (or install). Win7 then allowed me to install. I tried winXP again and it still doesnt allow me to install. It still has a problem. Any ideas? –  acidzombie24 Jun 30 '10 at 22:09

Boot from the W7 DVD and delete all the partitions during set up, skip the format tool, just continue with installing W7 on the unallocated partition.

One Unallocated partition will be created when you delete all the partitions.

EDIT:

Download this FREE utility, make the bootable disc and use it to wipe the drive, then try installing again.\

http://www.killdisk.com/

share|improve this answer
    
how do i delete without the format tool? The only partition large enough (>1gb) windows 7 didnt allow me to install onto. James solved 1 problem. Win7 can now install and seems to be working fine. However winxp complains and wont even let me get to the screen to hit r for repair –  acidzombie24 Jun 30 '10 at 22:08
    
I was talking about starting over from scratch, Win 7 or XP can do it during setup when you install the OS. –  Moab Jun 30 '10 at 23:01
    
So was i. I got an error there and was like WTF! thus this question. (i have formated at least 30times with XP) –  acidzombie24 Jul 1 '10 at 0:16
    
Read my edit in my post above –  Moab Jul 1 '10 at 12:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.