Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem: When Windows 7 puts the display to sleep, Outlook 2007 and also Microsoft Office Communicator 2005 lose the connection to the Exchange server. When I unlock the computer, Outlook is logged out of Exchange and prompts me for credentials (although usually I have to restart Outlook to get it to reconnect).

The network connection is still active, e.g. other applications don't lose their connection to the network or Internet when Windows 7 puts the display to sleep.

I'm using a Dell E5400 notebook running Windows 7 Enterprise 64-bit with Outlook 2007 connecting to a corporate Exchange server (not sure if it's Exchange 2007 or 2010). The Dell is typically docked and connected via DVI (through the dock) to two Dell monitors.

The Power Options in Windows 7 are set as follows:

  • Turn Off The Display: 15 minutes
  • Put The Computer To Sleep: never

Those are the "Plugged In" settings but the problematic behavior is the same when running on battery.

When Windows 7 turns off the display, it automatically locks the computer. E.g., I have to re-enter my credentials to access the machine. This is per corporate policy.

The equivalent set up on my previous Dell notebook running Windows XP SP3 did not result in this problem with Outlook 2007 or Office Communicator 2005 connecting the very same exchange server. The problem began when I switched to the new Dell E5400 with Windows 7.

share|improve this question
    
How are you connected to the network? (Wired/wireless) –  GalacticCowboy Jul 1 '10 at 16:01
add comment

2 Answers

In Control Panel, open Device Manager and expand the "Network Adapters" folder. Right-click on your network adapter and choose "Properties". The last tab is "Power Management". Is the box checked that says "Allow the computer to turn off this device to save power"? If this is on, try toggling it off and see if it makes a difference.

share|improve this answer
add comment

Set the following registry key to: ffffffff

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\autodisconnect

http://support.microsoft.com/kb/297684

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.