Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get "Can't find Language DLL msain900.dll" in an alert box when I try to run access (both when opening an existing database and when just running it) and in any mode (regular and safe mode).

Is there a way to prevent this DLL from being required?

Update: I got a copy of msain900.dll from a co-worker and I put it in both System32 and in Office12; neither helped. (FYI: You can't use regsvr32 on this DLL; it's not a system file.)

share|improve this question
    
A couple of links from Googling this issue point to uninstalling trial versions of newer MS Office versions. Did you install anything like this recently? –  Isxek Jul 1 '10 at 16:37
    
No, I didn't. I even got a copy of the DLL from a co-worker and tried putting it in System32 and Office12. All to no avail. –  grammar31 Jul 2 '10 at 15:24
    
Where are you getting the report that the DLL is missing? –  David W. Fenton Jul 2 '10 at 22:41

2 Answers 2

It appears the fix I have for MS Access 2007 also fixes a MS Word 2007 issue.

Access error:
When tryng to open Access after the 2007 upgrade you get the following error - “Can’t find Language DLL, MSAIN900.dll”

Word error: No page numbering, missing the 1033 folder & building blocks.dotx file inside it under C:\Documents and Settings\Your User Name\Application Data\Microsoft\Document Building Blocks

The fix:

Add/Remove Programs Go to MW Office 2007 and click “change” Check Add or remove features Highlight Access & click continue.

After it has done its thing, go to Access in the All programs menu & it will open without the error. No reboot required. Also the 1033 folder & building blocks.dotx file is there and page numbering is available in word.

The whole thing takes less than 5 minutes.

share|improve this answer

I tried reinstalling Office several times (once using a corporate installer; another time manually). Finally, I just used an install CD and reinstalled Office. Now Access opens without error.

This is an effective, but unsatisfying, solution. For the record, the versions I copied into System32, Office12 and Office12\1033 were all untouched, so I still don't know where it was supposed to go (although it doesn't seem like that knowledge would have helped).

share|improve this answer
    
If you had a broken installation why would you expect it to work? Re-installing fixed the broken installation, so why is that not satisfactory? –  David W. Fenton Jul 8 '10 at 2:47
1  
@David: I suppose my point is that it's not clear how it came to break. Since the rest of Office worked fine and several rounds of reinstalling Office did nothing, it's also not clear how another re-install fixed it (although clearly it did). "Unsatisfactory" refers to the explanation of the events not to the end-result. –  grammar31 Jul 8 '10 at 20:24
    
There's a long, long history of the Office installers being unable to repair themselves and requiring a complete removal and re-installation. If you've never encountered it before, you're actually quite lucky! In general, though, it's mostly caused by mixed versions, and mixed installs (e.g., installing Office SBE and then installing Access from Office Pro -- this can easily mess things up). –  David W. Fenton Jul 9 '10 at 23:23
    
@David: I'm not that lucky; I've had my share of non-repairable Office installations, but I've always been able to uninstall at the very least. This time, I couldn't uninstall nor did re-installing do anything (until it did). Thanks for trying to help, though. –  grammar31 Jul 11 '10 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.