Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to enter the number 3.10 into a field in Openoffice Calc. Unfortunately, the default setting is to be "smart" and reformat my input as 3.1. Since my column represents section headers, 3.10!=3.1. Also, my document is a CSV file, so I can't reformat the cell as a "-1234.12". How do I disable Calc's autoformating features?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

If the cell in the csv file is quoted, e.g. "3.10" and the csv text import box "Quoted field as text" is checked, then the imported value is 3.10 as a text entry.

You can format the header cell as text, then edit it to be 3.10. It will then be exported in the csv file as "3.10" and will import correctly.

If you need the value as a number elsewhere in the spreadsheet, then you can get it using the value() function.

share|improve this answer
    
Doesn't really work, but the best answer so far... –  Cerin Feb 22 '11 at 15:30
add comment

I don't know if you can disable autoformating.

But you can format column's cells, in your case to 2 decimal places.

Format -> Cells... -> Numbers -> Options -> Decimal places.

share|improve this answer
    
I explicitly said I can't do this because I'm using a CSV file... This setting would be lost immediately after closing Calc. –  Cerin Jul 1 '10 at 16:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.