Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some difficulty getting the Windows Home Server Connector to work on multiple machines. My Home Server server is up and running and working perfectly with my main PC (which has the Connector installed). Now I'm trying to install the Connector on subsequent PCs with no luck.

On the client PCs, I run the Connector installer. An error occurs after being prompted to enter my WHS password:

This operation cannot be completed at this time. Please try again later. If the problem persists, please contact Product Support.

At this point, my only option is to back out of the Connector installer.

This is the details of the event in the Event Log:

Server ID is not set yet. On the client it means that the server discovery (discovery.exe) was not run or was not run successfully.

I have tried getting the Connector working of a variety of machines now, so I don't believe that the error exists on the client end.

Any solutions or suggestions?

share|improve this question
    
How are you installing the client? from the server share? or from a local copy of the connector software? –  Omar Shahine May 2 '09 at 15:33
    
I've tried both server:55000 and \\server\Software. –  Matt Hanson May 2 '09 at 15:39
add comment

migrated from serverfault.com Jul 1 '10 at 20:01

This question came from our site for professional system and network administrators.

6 Answers

up vote 3 down vote accepted

I would copy the entire Home Server Connector software to your local drive and run it from there. In a few cases I've had failures where running directly from the home server failed but running the exe from the local machine worked fine.

share|improve this answer
add comment

Check the time zones on your home server and your client machines. I once had that problem and I resolved it using the same time zones on all machines.

share|improve this answer
    
Wow, who knew? Thanks! –  Matt Hanson May 15 '09 at 15:34
add comment

Try turning off the firewall on your systems for a few minutes to see if they're blocking your communications (remember to turn it back on afterwards).

If you're running OneCare (which overrides the default Firewall), check to ensure that it isn't locking you down with its firewall. I've had it reset to a Public security configuration after it pulls down updates in the past, which blocks many network services.

share|improve this answer
add comment

When I've had similar problems installing the WHS connector software, it's been because the client has had trouble finding the server. What's your network setup like? Wired/wireless? Are these other PCs connected the same way your main PC is?

share|improve this answer
add comment

I'll bet you're using non-ANSI characters in your system password. For some reason, they boogered the handling of the password in the web-service protocol that the Connector uses to talk to the server. I've got an open issue on the Microsoft Connect about this (as well as one they shouldn't have closed.

So, change the WHS Administrator password to a (much less secure) one that doesn't have extended-characters in it.

share|improve this answer
add comment

"I'll bet you're using non-ANSI characters in your system password. For some reason, they boogered the handling of the password in the web-service protocol that the Connector uses to talk to the server. I've got an open issue on the Microsoft Connect about this (as well as one they shouldn't have closed.

So, change the WHS Administrator password to a (much less secure) one that doesn't have extended-characters in it.

How rediculous is this. They make you use characters to have a safe password! First they dont update to PRPP1 and dont tell anyone, now this. Many frustrations with MS products lately.

After PP2 force update I can not get the connector software to install on any of my machines. This reminds me of the old days of win95/98 when MS had no clue..... They dont seem to learn!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.