Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I was trying to open a Virtual PC file that was in .exe format, so I went and pressed Open With, and selected Virtual PC. I pressed ok and then tried to open it, but it didnt work. Unfortunately, I forgot to uncheck "use this program for all files of the same type".

How do I undo the file association and get my PC working again?

share|improve this question

marked as duplicate by Ben N, nc4pk, DavidPostill windows Jan 23 at 17:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5  
The extraneous exclamation marks and saying please over and over really don't make people want to help you. Plus some proper capitalization and overall structure would be very helpful in getting questions answered in the future. – Daisetsu Jul 2 '10 at 0:02
2  
Thanks quack quixote for the edit/rewrite – TheLQ Jul 2 '10 at 11:07
  1. Open Command Prompt by typing cmd in RUN dialog box.

  2. Now provide following command: cd\windows

  3. It'll activate Windows folder. Now provide following command to open Registry Editor: regedit

  4. Now goto following key: HKEY_CLASSES_ROOT\.exe

    In right-side pane, change the value of Default key to exefile

  5. Now goto: HKEY_CLASSES_ROOT\exefile\shell\open\command In right-side pane, change value of Default key to: "%1" %*

  6. That's it. Now exit Registry Editor and restart your Windows. Now you should be able to open EXE files without any problem.

Source

share|improve this answer
1  
Would that be... cmd.exe, by any chance? May have luck with command.com, though even then I'm not entirely sure how to interact with the registry without using reg.exe. Perhaps you could roll up the changes into a .reg file, that should work? – Phoshi Jul 2 '10 at 16:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.