Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've configured Textpad to not allow multiple instances but Textpad still sometimes opens multiple windows. Any ideas?

share|improve this question
1  
Does the setting revert every time you close and reopen? – random Jul 3 '10 at 1:06
    
No, it appears to always be unchecked.. This always worked on my prior workstations (this is a new box).. – Marcus Leon Jul 7 '10 at 15:05
up vote 4 down vote accepted

Appears to be because I had the "Replace Notepad" preference (General area) selected. When we opened a file configured to use Notepad, this would open an add'l Textpad window. Fix is just to set Textpad to be the default program for the file types currently configured to use Notepad.

share|improve this answer

I've had this problem with Textpad 7 running under Windows 7, where regardless of whatever the "allow multiple instances to run" setting in the configuration was Textpad would always open a new instance when a file is opened with the "Open with Textpad" from the Windows explorer context menu. It creates another "Open with existing session" menu but that is more clicks I don't need. Very annoying.

  1. Locate the class ID in the registry for Textpad's entry in the explorer context menu, which should be {8A791F0C-C63C-4EC5-B97F-FBCE74EDBC54}. If you can't find this for your version of Textpad then locate the class ID from the HKCR*\ShellEx\ContextMenuHandlers\Textpad(Default) key

  2. Search for that class ID and you should see an AppOptions subkey, set to "-q -m" by default

  3. Remove the "-m", which is forcing Textpad to open new instances regardless of the configured setting

  4. Solved!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .