Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just finished building a new computer and I am now trying to set up wireless (sadly, wired is not an option). I am using a TP-Link USB adapter and a Netgear router. My OS is Windows 7 64bit. I have installed all relevant drivers.

On my desktop, I can detect the network, but all attempts to connect fail. As per usual, the windows troubleshooting process quickly and resolutely failed. I can connect wirelessly on two other laptops. I do not use encryption, but rather a MAC address whitelist, to which I have added the new machine's address.

How can I go about solving this problem?

share|improve this question
    
When you say connect fails, do you mean connection to other computers on the network and/or internet connection? –  CGA Jul 3 '10 at 6:49
    
I mean that after selecting the network from the list, a window pops up in the bottom right corner of the screen saying that "Windows could not connect to NETGEAR", which is the SSID of the router. –  CannedYerins Jul 3 '10 at 8:34

2 Answers 2

up vote 0 down vote accepted

Try turning off mac address filtering for a minute to see if you are able to connect. If you are able to connect, something probably went wrong with your mac address white-list. Maybe there is a typo in the mac address or you forgot to save?

Did you copy the mac address off the sticker on the device or did you use ipconfig /all or getmac?

Also make sure you have the latest driver.

Also note that Mac addresses are in Hexidecimal so you can only have characters 0-9 and A-F. If you have any i's or o's, you'll need to change them to 1's and 0's.

share|improve this answer
    
I turned off the filtering and got the same result. I got the latest driver and acquired the MAC address via the command prompt. It's correct in my list. Thanks for the reply. –  CannedYerins Jul 3 '10 at 8:30
    
@CannedYerins Usually wireless network tools (including the one provided with Windows) save network credentials and settings. Have you tried deleting the saved wireless network connection and letting it auto detect the settings again? –  James T Jul 3 '10 at 9:15
    
This is probably the weirdest part in that there is no wireless connection saved because I've never actually successfully connected. –  CannedYerins Jul 3 '10 at 18:03
    
@CannedYerins Are you able to connect to other wireless networks other than your own? It is beginning to sound like a defective wireless adapter. –  James T Jul 3 '10 at 23:27
    
No. The only other one in range is locked with a password, and I agree with your diagnosis. I'll call TP-Link's tech support and then probably replace it. –  CannedYerins Jul 4 '10 at 3:40

First thing I'd do is check the security settings for WEP or WAP, which ever you're using. Also check the SSID and the channel settings.

So, log onto the router via the admin interface, establish the settings for the above, then ensure your usb adapter is configured appropriately.

share|improve this answer
    
Sadly, I don't even know where I'd go to configure the USB adapter. There is no software that came with it which I could use to configure it, and the properties under Device Manager don't seem to be relevant to any of the things you mentioned. As I said though, my router has no security enabled in the form of encryption, only a MAC address list. It uses channel 11, which I thought to be a reliable channel. Is there some place to configure the device that I'm missing? Thanks for the help. –  CannedYerins Jul 3 '10 at 7:04
    
Did you install the client utilities for the usb adapter, by default it will have created a link on your desktop? If not you can download the driver and client utilities from a link on the right of the page from the link you posted above. Run the client and see what it finds. –  Pulse Jul 3 '10 at 7:42
    
Out of the available downloads, there are the driver files and the installer, and another application that essentially seems to tell idiots how to connect to their router (it searches for networks, exactly the same thing windows is doing). There is no diagnostic or configuration software. If that application is what you were talking about, then it did the exact same thing that windows did: show me the network but not allow me to connect to it. –  CannedYerins Jul 3 '10 at 8:19
    
fair enough. All I was hoping to do is establish if the information being collected by the utility and/or windows matches the configuration of the router. The question is, is it a router configuration problem or a windows/tp-link problem. For now it may be worth setting the channel to 'Auto' and removing the MAC filtering, see what happens... –  Pulse Jul 3 '10 at 9:32
    
It seems that my router has no "auto" option for the channel, and I've already tried disabling the MAC filtering. Changing the channel to "6", which, as far as I know, is the other reliable channel, yields no results. –  CannedYerins Jul 3 '10 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.