Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The error I get:

The server's security certificate is revoked!

You attempted to reach, but the certificate that the server presented has been revoked by its issuer. This means that the security credentials the server presented absolutely should not be trusted. You may be communicating with an attacker. You should not proceed.

It works fine in Google Chrome.

share|improve this question

migrated from Jul 4 '10 at 0:24

This question came from our site for system and network administrators.

up vote 5 down vote accepted

This is a known issue that deals with having the incorrect system time set. Verify your system time against a network time server first then see if the issue reoccurs.

Here's the info on the bug:

share|improve this answer
Thanks. Meanwhile I worked it around by turning the certificate check off. – grigy Jul 3 '10 at 18:25
Synching the system time worked for me – Isaac Betesh Apr 3 '14 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .