Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All my other applications and Nautilus, when I open a folder, can display the menu perfectly, except for Filezilla. How do I use Alt + E to use the inner menu items?

The main menu is always invisible to me.

This is the screenshot:

Screenshot

share|improve this question

5 Answers 5

up vote 4 down vote accepted

A bit late to say this, but I had the exact same problem with Audacity in Ubuntu 10.10.

To fix it (this worked with both Audacity and FileZilla), do this:

Open up Terminal and type in:

sudo mv /usr/bin/filezilla /usr/bin/prog-filezilla

This renames the FileZilla executable. Now to make a fixed pseudo-executable, run this:

gksudo gedit /usr/bin/filezilla

Now with Text Editor open, type this into the file:

#!/bin/bash

export UBUNTU_MENUPROXY=0
prog-filezilla

This makes a sort of "sandboxed" FileZilla that uses the UBUNTU_MENUPROXY environment variable when you run it.

Now, just make the file executable:

sudo chmod a+x /usr/bin/filezilla

Now, just run the shortcut and you should have a sane-looking FileZilla! (As far as I can tell, this should work with more than just Audacity and Filezilla)

share|improve this answer
    
Hi what do you mean by just run the shortcut? it didnt work for me :( –  Kim Stacks Nov 9 '10 at 11:50
    
Don't you have a FileZilla shortcut in your Applications menu? Just run 'filezilla' from Terminal. BTW, what do you mean by "it didn't work"? Did it not fix the problem or did it not open at all? –  Blender Nov 10 '10 at 19:38
    
Had this issue with Ubuntu 12.10. This fixed it. This should be the accepted answer (especially since this is the first result when I googled it) –  slosd Oct 30 '12 at 20:15
    
** Alright, too fast... See my answer. ** –  slosd Oct 30 '12 at 20:25

It seems as if the menu bar is there, but has a zero height or is hidden behind one of the other UI elements. Try reconfiguring the UI to persuade the app to recalculate the position and height of it. For example, switch the various UI items on and off using the View menu. Or drag the toolbar around using the handle on its left hand edge.

Your screenshot looks as if you have the app maximized (ie 1280 pixels wide). Try unmaximizing it before you do all of this. Resize the window a few more times, too.

share|improve this answer
    
i tried this to no avail.. :( –  Kim Stacks Jul 6 '10 at 0:30

I had a similar problem with a single application which turned out to be a corrupted Gnome configuration file for that app (vim) only. It was both frustrating and utterly hidden. The file ~/.gnome2/Vim should contain the two lines:

[Placement]
Dock=Toolbar\\0,1,0,0\\Menubar\\0,0,0,0

but it didn't and I have no idea what corrupted it. Fortunately the fix was easy: remove the offending file and the next invocation of gvim recreated it. I don't run filezilla, but the syndrome is identical, and you'd never, ever think to look there.

share|improve this answer
    
I do run filezilla, and I don't see a ~/.gnome2/ file that might relate to filezilla. However, maybe @keisimone does have one and it's causing the problem. –  Neil Mayhew Jul 6 '10 at 0:18
    
i checked my gnome2 folder, but i cannot find either vim or filezilla. –  Kim Stacks Jul 6 '10 at 0:27

You seem to be saying that you have no menu bar in FileZilla, but that it still responds to menu accelerators such as Alt-E.

FileZilla keeps a record of all its settings, including the UI layout, in ~/.filezilla. Close FileZilla, rename that directory, and reopen the application to see if it brings the menu bar back. If it does, then you can manually merge files from the previous settings folder into the newly-created one to carry forward your site manager settings and bookmarks. The file names are all fairly self-explanatory and the content is XML so it can easily be viewed and understood.

If this doesn't work, try a forced reinstall of the FileZilla package. This can be done in Synaptic with Package > Mark for Reinstallation.

share|improve this answer
    
sorry didnt work. i am stumped :( –  Kim Stacks Jul 5 '10 at 2:27
    
You should really ask this question in the filezilla support forum forum.filezilla-project.org, since this seems to be a bug in filezilla rather than a question about how to do something, which is what superuser.com is really for. –  Neil Mayhew Jul 5 '10 at 22:05

Old question, but I had this issue after installing Ubuntu 12.10 and using Gnome-Shell instead of Unity. Uninstalling some appmenu packages seems to do the trick.

sudo apt-get remove appmenu-gtk appmenu-gtk3 appmenu-qt indicator-appmenu
share|improve this answer

protected by Diago Dec 17 '10 at 14:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.