Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 with 4GB of memory, and am running VMWare with 2GB of memory.

Every time I shutdown the VM, for some stupid (or overly smart) reasons, there is a lot of paging going on, and I simply can't do anything useful for about 3-5 minutes. This does not happen on Windows XP, where the memory gets claimed almost instantaneously.

Is there anything I can do to stop the paging?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Take a look at this blog. This guy had the same problem, and now he has solved it. Give it a try.

Posted by twig at 11:34 AM Sunday, March 1, 2009:

Ever since upgrading to VMWare v6.5.1, I've noticed it would take several minutes for my laptop to respond to input after closing VMware or pausing/shutting down a guest.

The excessive harddrive activity would halt my host operating system and prevent hibernation from working (causing me to nearly miss my train station several times!)

Luckily, someone's found the solution to fixing this problem by setting some hidden configuration options.

Open up your "guest.vmx" file in Notepad and paste the following lines at the end of the file.

mainMem.useNamedFile = “FALSE”
prefvmx.useRecommendedLockedMemSize = “TRUE”
prefvmx.minVmMemPct = “100″

This has stopped the excessive harddrive activity on my laptop and I have been able to get off the train on time.

share|improve this answer
    
As I am using VMWare player, this line fixes my problem: prefvmx.minVmMemPct = “100″ . Thanks! –  portoalet Jul 4 '10 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.