Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This issue is present since Firefox v3.6 and now it's 3.6.6 without any changes. When I start Firefox, it takes more than 5 minutes to start and it kills me. I have the same version at home with more addons, but it starts in 2 seconds. The slow Firefox is on an IBM R50e with 1 GB RAM (OK, this laptop is old but 5 minute starting time is still too much), Windows XP SP3, and the laptop is starting the other programs in an acceptable duration. Installed addons (all up-to-date):

  • AdBlock Plus
  • BugMeNot
  • DownThemAll!
  • Firefox Sync
  • GreaseMonkey
  • Java Console
  • Java Quick Starter
  • LocationBar2
  • Microsoft .NET Framework Assistant
  • Personas
  • QuickDrag
  • Tab Mix Plus
  • WebMail Notifier

One more thing: When I start Win XP and then start Firefox, Firefox takes more than 5 minutes to start. If I close and restart Firefox, it takes around a minute. So this issue seems to have something with the first start of FF after an OS reboot. Note that I tested FF's startup duration after Win XP starts properly loading all XP startup programs (Antivirus, Outlook, VNC, Office Communicator, SoundMax Control Panel, and Intel Graphics. That's all).

Any suggestions to ease my pain?

share|improve this question
    
5 minutes! And I thought my 10 seconds was slow! –  muntoo Sep 4 '11 at 20:06
add comment

3 Answers

up vote 2 down vote accepted

There are a number of factors that contribute to a slow start-up for firefox and even though the situation has improved considerably with the recent releases, it can still be problematical.

As I'm sure you appreciate, the environment under which you are running fx is a little limited, however, I believe things can be improved.

The first thing to do is start the browser in Safe Mode This might give us an idea about where the problems lay.

Other factors that contribute to the slow start-up are a large cache/history, so I'd recommend cleaning the data in these areas, either use the built-in cleaner, or, in my opinion, a better solution is CCleaner Using this utility will also allow you to clear the Temporary Internet files for Windows and will also be useful in the next step.

If you are using CCleaner, you will fine an option for firefox on the Applications tab to compact the databases. I's suggest running CCleaner with this option enabled. As an alternative you can use Vacuum Places Improved This does effectively the same thing.

Another suggestion is disabling firefox auto-update from the Options/Advanced/Update tab.

Finally, I'd suggest disabling any extraneous plug-ins you may have, such as the Java Deployment Toolkit.

At the end of the day, having done all of the above, it may still come down to a conflict between certain extensions and the only way to reslove those issues is to disable one by one until you identify which, if any, are to blame.

As an alternative to the above you could simply create a new profile However, I'd still recommend running a purge of the system withe something like CCleaner.

share|improve this answer
    
I tried safe mode and it took around a minute to open. Now I'll try to clean cache/history. –  Mehper C. Palavuzlar Jul 5 '10 at 11:04
    
Here is what I did: I cleaned cache/history. Then I disabled FF updates. I also installed Vacuum Places Improved and vacuumed places.sqlite with it. I uninstalled the following addons (I hope this does not cause any problems while surfing the net): Java Console and Microsoft .NET Framework Assistant. Then I rebooted the machine and started FF. It took a minute to start. So we have an improvement. I don't want to test my addons disabling one by one 'cause I need them all. 1 minute starting time is, of course, better now. If no answers come to shorten this duration, I'll accept your answer. Thnx –  Mehper C. Palavuzlar Jul 5 '10 at 11:25
    
No worries :) A minute is better than 5, so at least we're getting there. The .NET stuff is a pain, you should search on that for proper removal, it's not needed and there are lots about that subject. Don't forget to vacuum occasionally :) –  Pulse Jul 5 '10 at 11:38
    
Bad news again. Today, I clicked on FF shortcut with the hope of quicker opening, but it took 4 minutes again. I really don't understand why it behaved like that. I'm rebooting the machine, waiting for Antivirus and others to load, and then trying to open FF. There is something wrong here... –  Mehper C. Palavuzlar Jul 6 '10 at 6:39
    
I think it's worth creating a new separate profile, just as a test. It's easy enough to do and you can remove it if you find no improvement. Just create a short-cut to the firefox.exe and at the end of the 'target' line ad -p launcj firefox and follow the prompts, for now you can simplay place the profile folder on your desktop. Don't add anything to it and see how that start-up times compare. if, after using it for a while you find an improvement, we know it's a problem with the old profile and act accordingly. –  Pulse Jul 6 '10 at 7:30
show 1 more comment

Install Pale Moon. At least it gave me a huge speed boost even with a lot of addons. (In the terms of startup, etc. also!)

share|improve this answer
    
+1: Just tried this - an optimised Firefox - and it is noticeably faster. –  Umber Ferrule Jul 5 '10 at 9:22
add comment

I would recommend to run a scan for malicious software (Malwarebytes' will be great)

Also try to open Firefox w/o any plug-ins installed. There is a chance that one of them is causing this issue.

share|improve this answer
    
Also, you could try disabling all addons and then re-enable one by one to see which one causes most slow down. –  Umber Ferrule Jul 5 '10 at 9:12
    
I ran a full scan with Malwarebytes. No infections were found. –  Mehper C. Palavuzlar Jul 5 '10 at 11:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.