Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I turn off write cache in Linux? More specifically, SUSE 11?

My problem is that heavy IO kills the system even if the generating process is user priority class, and the starved processes are RR/RT class. So my high availability system breaks with lots of timeouts.

I have / mounted on a flash drive, and a few mount points looking into a RAID controller. For the RAID, I want to try to turn the cache off, since it has a cache inside. But if it needs to be system-wide, fine.

So far I used sync option to mount, but it's not quite like turning off the cache.

Any ideas?

Thanks, Alex

share|improve this question

migrated from stackoverflow.com Jul 5 '10 at 14:38

This question came from our site for professional and enthusiast programmers.

    
General rule to be real-time is not to mix the workloads, especially batch and interactive tasks. If you want a service to be real-time, then put it on a dedicated server. Otherwise, it would be interesting to hear if ionice suggested below would help alleviate the problem. –  Dummy00001 Jul 5 '10 at 22:48

4 Answers 4

up vote 2 down vote accepted

When mounting your hard drives use -o sync which will turn off write buffering for the drive.

You can also set it up in your fstab:

/dev/sda1    /    reiserfs        sync    0   0
share|improve this answer
2  
The OP says he already tried this. –  Sjoerd Jul 5 '10 at 14:31
    
yes, that's actually how you turn off file write caching. When I was asking the question I didn't know enough to ask correctly. Thanks! –  n-alexander Aug 20 '10 at 16:49

Maybe drop_caches can help you. It does not seem to disable the cache, merely clear it.

share|improve this answer
    
What's wrong with sync? –  amphetamachine Jul 5 '10 at 14:32

For a plain hard disk it would normally be

hdparm -W 0 /dev/sdX

but RAID controllers typically don't pass that through.

You'll have to check the configuration interface of your RAID controller for any options. It might not be possible.

share|improve this answer
    
hdparm affects the block device. Linux cache is much higher up –  n-alexander Aug 20 '10 at 16:48
    
I suppose it depends on which "write cache" he means. –  Peter Eisentraut Sep 4 '10 at 11:14

please have a look here: http://superuser.com/a/464382/106740 With http://code.google.com/p/pagecache-mangagement/, you can disable file caches on a per-application level

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.