Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to delete, rename and even force delete (using /F in cmd.exe) a bunch of files. These were created during some updates etc and in a different drive than C root drive. Using Windows XP SP3. Any help, suggestions?

CMD.EXE gives error access is denied while deleting

share|improve this question
    
Are you logged on as a user with local administrator rights? –  Kez Jul 5 '10 at 17:24
    
Yes I am logged in as Admin user (The only account on machine). –  Jasmine Appelblad Jul 5 '10 at 17:26
    
@kez, do you know how can I get full ownership of file? this might help –  Jasmine Appelblad Jul 5 '10 at 17:30
    
as harrymc mentioned, support.microsoft.com/kb/308421 will talk you through how to do it. It's not as scary as it looks. –  Kez Jul 7 '10 at 12:30

5 Answers 5

up vote 1 down vote accepted

The files might have strange permissions, and you might not be their owner.

See: How to take ownership of a file or a folder in Windows XP.

share|improve this answer
    
It worked. It was all about ownership of file as "Full COntrol" –  Jasmine Appelblad Jul 11 '10 at 11:56

This really worked:

  1. Start in Safe Mode
  2. Log in as Administrator
  3. In My Computer, rename (may not be necessary)
  4. Right click on the file and choose Properties.
  5. Select the Security tab.
  6. Tick "Full control" which automatically ticks all the other boxes as well.
  7. Click "Apply" and then "OK"
  8. On the file, right click and "delete".

I had hundreds of sub-folders with these EULA files. They were all Microsoft warnings about the use of some Microsoft product I had downloaded, in about fifty different languages. Don't you just hate the sheer arrogance of Microsoft stopping you controlling your own computer?

This worked for me. After rebooting several times they have not reappeared. I now need to check what other crud was installed by Microsoft without my consent, and take back control.

share|improve this answer

You might check out a freeware solution: Unlocker

share|improve this answer

They are probably system level files that Windows is protecting. Windows (as far as I know) doesn't have a sudo "I want this done and done now" mode at all.

share|improve this answer
    
The files are eula.rtf, The package was downloaded during an update process. –  Jasmine Appelblad Jul 5 '10 at 17:20
1  
@Zai: And if the system created them it might still be protecting them. –  Josh K Jul 5 '10 at 17:23

Reboot in Safe Mode and then try to delete them as an administrator.

You should also be able to boot off a 3rd party OS disk (like a Linux Live CD, or a Windows PE disk) and go remove them, that way your copy of Windows CAN'T stop you. :)

HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.